Page MenuHomePhabricator

Fatal error when using ReCaptchaNoCaptcha with ContactPage
Closed, ResolvedPublic

Description

Hello,

I am using ReCaptchaNoCaptcha and ContactPage 2.2 on my wiki (version 1.26).
I get this error when I set $wgCaptchaTriggers['contactpage'] to true:

Catchable fatal error: Argument 1 passed to ReCaptchaNoCaptcha::getForm() must be an instance of OutputPage, none given, called in /home/pierre/www/archi-mediawiki/extensions/ContactPage/ContactPage_body.php on line 488 and defined in /home/pierre/www/archi-mediawiki/extensions/ConfirmEdit/ReCaptchaNoCaptcha/ReCaptchaNoCaptcha.class.php on line 8

Event Timeline

Rudloff created this task.May 22 2016, 7:55 PM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald TranscriptMay 22 2016, 7:55 PM
Kghbln closed this task as Resolved.Mar 23 2018, 6:00 PM
Kghbln claimed this task.
Kghbln added a subscriber: Kghbln.

I just tested with the following setup:

  • MediaWiki 1.27.4 (f581561) 16:58, 3. Mär. 2018
  • PHP 5.6.33-0+deb8u1 (apache2handler)
  • MySQL 5.5.59-0+deb8u1
  • ContactPage 2.2 (c139343) 00:45, 18. Mai 2016
  • ConfirmEdit 1.4.0 (f8c63df) 17:02, 6. Jul. 2017

I am not getting this issue with e.g.

wfLoadExtensions( [
	'ConfirmEdit',
	'ConfirmEdit/ReCaptchaNoCaptcha'
	]
);
$wgCaptchaClass = 'ReCaptchaNoCaptcha';
$wgReCaptchaSiteKey = 'xxx';
$wgReCaptchaSecretKey = 'yyy';
// $wgCaptchaTriggers['edit'] = true;
// $wgCaptchaTriggers['create'] = true;
$wgCaptchaTriggers['addurl'] = false;
$wgCaptchaTriggers['contactpage'] = true;

It must have been resolved in the meantime. I believe to remember that ConfirmEdit was creating multiple issues with MW 1.26 which have been fixed in the meantime. Probably this issue was one of them. Thus closing.

Kghbln removed Kghbln as the assignee of this task.Mar 23 2018, 6:01 PM

I confirm I can't reproduce anymore with MediaWiki 1.29.2, ConfirmEdit 1.29+6925a22 and ContactPage 1.29+d269558.