Page MenuHomePhabricator

WDQS returns deleted and redirected items
Closed, ResolvedPublic

Description

@Daniel_Mietchen submitted this query:

SELECT DISTINCT ?item ?pubyear WHERE {
  ?item wdt:P577 ?pubdate;
        wdt:P31 wd:Q13442814.
  BIND(year(?pubdate) AS ?pubyear).
  MINUS { ?item schema:description ?itemDescription. }
}
LIMIT 10

Query link

Currently, it returns these results:

The first two items have been deleted, the rest are redirects. As far as I know, WDQS isn’t supposed to return deleted items at all, and redirects should only appear when explicitly selected with owl:sameAs, so I assume this must be stale data.

This may be a dupe of T136393, and I suppose T153513 would resolve this issue.

Event Timeline

Restricted Application added projects: Wikidata, Discovery. · View Herald TranscriptJan 22 2017, 10:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Yes, these seem to be still April deletes. Reload will get rid of them, but still waiting for hw to be ready. In the meantime, I've updated the IDs affected.

Smalyshev triaged this task as High priority.Jan 22 2017, 10:26 PM

Looks like redirects are more recent though, need to look into it...

Smalyshev closed this task as Resolved.Feb 14 2017, 9:39 PM
Smalyshev claimed this task.

Do not see it anymore after the reload. Also, I suggest replacing MINUS with this:

SELECT DISTINCT ?item ?pubyear WHERE {
  ?item wdt:P577 ?pubdate;
        wdt:P31 wd:Q13442814.
  OPTIONAL { ?item schema:description ?itemDescription. }
  FILTER(!bound(?itemDescription))
  BIND(year(?pubdate) AS ?pubyear).
}
LIMIT 10