Page MenuHomePhabricator

Local edit notices not displayed as expected on ms.wikipedia.org
Closed, ResolvedPublic

Description

I have imported all the needs for edit notice system to be working. But I think there a problem lies in [[:ms:MediaWiki:Editnotice-0]] and [[:ms:MediaWiki:Editnotice-1]] (maybe all MediaWiki:Editnotice prefix have this problem) because it is not displaying what it should be like in English Wikipedia. I found out that they need phab them here first before they work in local wiki.

If so, I would like to put this system into Malay Wikipedia.

I use my user talk page as references.

First in English wiki is displaying what actually need to appear when editing.

But when I do it in Malay wiki, The red links are appear like I miss something in coding.

I know that all the headers like in English wiki need all the MediaWiki:Editnotice-0, 1, 12 and etc. (All pages with prefix MediaWiki:Editnotice) based on what namespace did you edit.
I had copy all the template coding that is Template:Editnotice and all it's core subpages (All prefix with Template:Editnotice) into MediaWiki:Editnotice-0, 1, 12 and etc. to make this editnotice system work based on what I read in Wikipedia:Editnotices.

Feel free to tell me if there is no enough info regarding to this problem.

Event Timeline

SNN95 created this task.Apr 11 2017, 7:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 11 2017, 7:56 PM

Hi @SNN95, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem, please add a more complete description to this report (a list of steps to reproduce which leave no room for interpretation what to do, describing actual results and expected results after performing the steps to reproduce, and most important: Full links where to see the problem, and what to see "like in English Wikipedia").
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

I found out that they need phab them here first before they work in local wiki.

Who is "they" and "them" in that sentence?

SNN95 added a comment.EditedApr 13 2017, 12:32 PM

Sorry for my bad English, @Aklapper. They and them in this context are all templates and MediaWikis namespace included for making this editnotice working.

I only want to fix this editnotice in default mode.

I use [[w:en:Template:BRT Sunway Line|Template:BRT Sunway Line]] as example vs in ms.wiki

What I expected from this editnotice thing is whenever I click "edit" on various namespaces, the view should be like in [[w:en:Template:BRT Sunway Line|Template:BRT Sunway Line]] with no red link of "Page notice Group notice", but when in ms.wiki, red links of "Notis kumpulan Notis laman" will be visible even though I put all the id class for not display the red link in ms.wiki MediaWiki:Common.css.

Is there any missing id class or whatever relating to this editnotice that I miss to put or put in the wrong way into the system?

FYI, when edit all Mediwiki, IP userspace and Module page, the editnotice is responding well but not in Main, Template, some subpages, etc.

@SNN95: I do not know where to find "this editnotice thing" which you refer to. I don't know where to see red links of "Notis kumpulan Notis laman".
When I click on "edit source" and end up on https://en.wikipedia.org/w/index.php?title=Template:BRT_Sunway_Line&action=edit I do not see any red link.
Could you please provide complete links (https://something) to things that you refer to, so others could take a look? Could you please provide a list of steps to reproduce the problem, step by step, in a separate section? And explain what you expect to see, and what you actually see, in two separate sections?
Please see https://mediawiki.org/wiki/How_to_report_a_bug and edit the task description. Thanks!

Aklapper changed the task status from Open to Stalled.Apr 15 2017, 10:33 AM

@SNN95: Could you please follow the last comment and provide missing information?

SNN95 updated the task description. (Show Details)Apr 19 2017, 5:12 PM

Ah, thanks a lot! Has this problem been brought up at https://en.wikipedia.org/wiki/Wikipedia_talk:Editnotice already? Because if the instructions on https://en.wikipedia.org/wiki/Wikipedia:Editnotice are not clear, that might be the actual problem instead?

I don't (yet) see how this is an issue with the configuration of Wikimedia servers (instead of some changes on-wiki, creating or editing content of wiki pages on ms.wikipedia.org). I might be wrong though, because the underlying problem (why is your edit notice not displayed on ms.wikipedia.org) is unclear. :-/

Aklapper renamed this task from Deal with ms.wikipedia.org's edit notice system to Local edit notices not displayed as expected on ms.wikipedia.org.Apr 19 2017, 7:30 PM
SNN95 closed this task as Resolved.Apr 19 2017, 8:25 PM
SNN95 claimed this task.

I think I know why the red links still visible. I tried with my second account which is not a sysop (Nazhana95) and log out using only IP address username, I found out the red links are not visible anymore. To confirm that, I tried to switch back to my primary account (SNN95), and found out the red links are visible again.

Maybe because I put this code in Malay Common.css, so all other users that are not sysop will be not see the red links:

/* Hide the red "Group notice" and "Page notice" links. */
.editnotice-area .editnotice-redlink {
  display: none !important;
}

So I concluded this problem, it is maybe the sysop account that always make me to see the red links. After all your solutions to digging far deeper after so many troubleshoots, it is all cause by visibility for each users.

Sorry for keeping you to resolved my Malay wiki problems, and thanks again!

No worries! Glad it works for you now!