Page MenuHomePhabricator

badfilename error when uploading recording of word “Kunstraum Kreuzberg/Bethanien”
Closed, ResolvedPublic

Description

Issue posted on github by @LucasWerkmeister:

I used the “Nearby items” feature of the record wizard, and one of the suggested items was Kunstraum Kreuzberg/Bethanien. After recording that word, the recording could not be uploaded; dev tools reveal the following API error:

{
  "upload": {
    "result": "Warning",
    "warnings": {
      "badfilename": "LL-Q188_(deu)-Lucas_Werkmeister-Kunstraum_Kreuzberg-Bethanien.wav"
    },
    "filekey": "redacted.redacted.58.wav",
    "sessionkey": "redacted.redacted.58.wav"
  }
}

I’m not sure what exactly is causing the error – the slash in the word seems like the obvious candidate, but the filename mentioned in the warning has no slash, so I’m not sure if that’s the real culprit.

Event Timeline

0x010C created this task.Jun 11 2018, 10:25 AM
0x010C triaged this task as High priority.Jun 11 2018, 10:30 AM
0x010C closed this task as Resolved.Jun 11 2018, 11:16 AM

the slash in the word seems like the obvious candidate

Yes it is the cause of the warning, the filename mentioned is a proposal from MediaWiki for a legal filename.

According to Manual:$wgIllegalFileChars, this is the list of all illegal characters: #<>[]|{}:/\.
For now on, they all will be replaced by a dash (as MediaWiki suggest to do), cf. this commit.

Vvjjkkii renamed this task from badfilename error when uploading recording of word “Kunstraum Kreuzberg/Bethanien” to gabaaaaaaa.Jul 1 2018, 1:04 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed 0x010C as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
CommunityTechBot renamed this task from gabaaaaaaa to badfilename error when uploading recording of word “Kunstraum Kreuzberg/Bethanien”.Jul 2 2018, 8:25 AM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to 0x010C.
CommunityTechBot updated the task description. (Show Details)