Page MenuHomePhabricator

Rollback confirmation gadget: Buttons are flipped on iPhone
Closed, InvalidPublic

Description

Here's what happens to me:

  1. Open Wikipedia watchlist in Safari on iPhone 5s.
  1. Click rollback next to an edit.
  1. Confirmation dialogue opens. "Cancel" rolls back the edit. "OK" cancels.

The buttons are flipped! Dangerous!

Tested on phone several times. Always the same result.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 19 2019, 12:35 PM
Tim_WMDE added a subscriber: Tim_WMDE.EditedMar 26 2019, 9:52 AM

Hey, I have tried to reproduce this issue but I don't see the behavior you describe. I have also double-checked it on other pages like RecentChanges, it seems to work fine everywhere. Does the issue still occur for you? If it does, which iOS version are you using exactly?

This could also be related to language settings, which exact wiki did you use with what kind of language?

Popcornduff added a comment.EditedMar 27 2019, 2:47 AM

I can still reproduce the bug. The only thing that’s inconsistent is whether you roll back your own edits or not. It seems to only be consistently broken when I revert edits made by other accounts, not my own.

This does it for me:

  1. Log out and edit my sandbox (https://en.wikipedia.org/wiki/User:Popcornduff/sandbox) in incognito mode. (I did this part on my laptop, not my phone.)
  2. Log into user account on iPhone.
  3. On iPhone, go to Wikipedia in Safari (desktop mode, not browser mode).
  4. Go to my sandbox page.
  5. Go to View history.
  6. Next to the most recent edit summary, tap Rollback. Dialog opens: “Rollback edits by <IP number>”? Options are Cancel or OK.
  7. Tap Cancel and the edits are rolled back.

I'm using the English Wikipedia in English.

I'm using an iPhone 5s, Safari, iOS 12.1.4.

edit: just updated to latest version, 12.2. Same problem.

Tim_WMDE added a subscriber: Krenair.

Hey, I think there is a bit of a mix-up here, I thought you were testing on Beta Wikipedia because our rollback confirmation change has not actually been deployed to the live Wikipedias yet. I am not sure what this feature is you are talking about, my best guess right now would be that you have some sort of Gadget enabled that does this, but I could be mistaken.

@Krenair just wanted to ping you here that you are aware I removed the project tag from this ticket and that it needs to potentially be re-assigned.

Popcornduff added a comment.EditedMar 29 2019, 2:55 PM

You're right - I have this script enabled, which I'd completely forgotten about... https://en.wikipedia.org/wiki/User:MusikAnimal/confirmationRollback-mobile

So it's presumably a problem with this script. Should the bug be closed here?

Sorry for the confusion!

JJMC89 closed this task as Invalid.
JJMC89 added a subscriber: JJMC89.

User script bugs are not tracked on Phabricator.

JJMC89 removed a subscriber: JJMC89.Mar 29 2019, 6:34 PM
Aklapper renamed this task from Rollback confirmation buttons are flipped on iPhone to Rollback confirmation gadget: Buttons are flipped on iPhone.Mar 29 2019, 6:36 PM