Page MenuHomePhabricator

Error viewing project feed when many recent changes were in access restricted tasks: "Query (of class "PhabricatorFeedQuery") overheated: examined more than 500 raw rows without finding 50 visible objects"
Open, Needs TriagePublic

Description

procurement : https://phabricator.wikimedia.org/project/profile/1155/

Unhandled Exception ("Exception")
Query (of class "PhabricatorFeedQuery") overheated: examined more than 500 raw rows without finding 50 visible objects.

Event Timeline

Restricted Application added a project: Upstream. · View Herald TranscriptWed, Aug 7, 9:21 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Aklapper renamed this task from Unable to view a Phabricator project to Cannot view Phab project: "Query (of class "PhabricatorFeedQuery") overheated: examined more than 500 raw rows without finding 50 visible objects".Wed, Aug 7, 9:43 AM
Aklapper changed the task status from Open to Stalled.

Cannot reproduce with the given link.

Did you find the issue while logged out?

@Bugreporter: Does it require being logged out?

Aklapper changed the task status from Stalled to Open.EditedWed, Aug 7, 10:07 AM

Ah, I see now, thanks. I can reproduce this when using my personal Phab account. I guess this has to do with access restrictions on tasks and trying to construct a feed of public stories on https://phabricator.wikimedia.org/project/profile/1155/ (while with my work account I can access more access-restricted tasks).

Aklapper renamed this task from Cannot view Phab project: "Query (of class "PhabricatorFeedQuery") overheated: examined more than 500 raw rows without finding 50 visible objects" to Error viewing project feed when many recent changes were in access restricted tasks: "Query (of class "PhabricatorFeedQuery") overheated: examined more than 500 raw rows without finding 50 visible objects".Wed, Aug 7, 10:08 AM
epriestley added a subscriber: epriestley.

This should be resolved upstream by https://secure.phabricator.com/D20704.