Named anchors not working in preview
Closed, DeclinedPublic

Description

When using a named anchor in a link, e.g. [[Economics#See also]], if you preview the page before
submitting your edits and then follow the link in the preview, the named anchor isn't found (the link
will go to the top of the destination article). Once the page has been saved it works fine and takes you
to the relevant section of the destination article as it should.


Version: unspecified
Severity: minor
OS: Windows 2000
Platform: PC

bzimport added a project: MediaWiki-Page-editing.Via ConduitNov 21 2014, 6:48 PM
bzimport added a subscriber: wikibugs-l.
bzimport set Reference to bz383.
HappyDog created this task.Via LegacySep 5 2004, 4:57 PM
brion added a comment.Via ConduitSep 5 2004, 7:44 PM

Can't reproduce. Tried putting [[Economics#See also]] in the sandbox on en.wikipedia and previewing; the link worked fine.

HappyDog added a comment.Via ConduitSep 6 2004, 11:15 AM

I've done a little further experimenting and realised that the problem wasn't with the preview, but with the 'open in new window' function (which I always
use in preview so my edits aren't lost, but don't tend to use when browsing the 'pedia.) I have opened a new bug report with this info.

HappyDog added a comment.Via ConduitNov 5 2007, 9:38 AM

Note - the bug report mentioned above is bug 399, resolved INVALID (Internet Explorer issue).

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.