Named anchors don't work when opening in new window
Closed, InvalidPublic

Description

It seems that if you open a named anchor (e.g. [[Economics#See also]]) in a new window then the browser
stays at the top of the page, and doesn't jump to the appropriate section as it should. This only
happens when you open in a new window. It works fine if you follow the link within the same window.

I am using ie version 5.50.4807.2300 on Windows 2000, and am opening the link by shift-clicking or by
right-clicking and selecting open in new window. I tested this in the sandbox on en.wikipedia using
[[Economics#See also]].


Version: unspecified
Severity: minor
OS: Windows 2000
Platform: PC

Details

Commits
Unknown Object (Diffusion Commit)
Unknown Object (Diffusion Commit)
Unknown Object (Diffusion Commit)
Reference
bz399
bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz399.
HappyDog created this task.Sep 6 2004, 11:19 AM
brion added a comment.Sep 6 2004, 7:52 PM

Works for me in Safari 1.2.3 and IE 6.0/Windows XP. It's a bug in your old version of Internet Explorer; we can't do anything about it. Either
upgrade or report it to Microsoft.

That's cool - so long as it's not a general bug. To be honest, I would have been surprised if it was a bug within Wikipedia, but thought I'd better report
it anyway (could be symptomatic of something else maybe?). Won't bother reporting to Microsoft as they won't give a toss.

  • Mark
Diffusion added a commit: Unknown Object (Diffusion Commit).Mar 4 2015, 8:20 AM
Diffusion added a commit: Unknown Object (Diffusion Commit).
Diffusion added a commit: Unknown Object (Diffusion Commit).

Add Comment