Page MenuHomePhabricator

EXCEPTION: (AphrontParameterQueryException) Array for %Ls conversion is empty. Query: phid IN (%Ls) at [<phutil>/src/xsprintf/qsprintf.php:252]
Closed, ResolvedPublic3 Estimated Story Points

Description

I tried the Phabricator sprint extension and get following error when trying to access /project/sprint/:

Unhandled Exception ("AphrontParameterQueryException")
Array for %Ls conversion is empty. Query: phid IN (%Ls)

The webserver error log shows:

[2015-02-09 18:26:21] EXCEPTION: (AphrontParameterQueryException) Array for %Ls conversion is empty. Query: phid IN (%Ls) at [<phutil>/src/xsprintf/qsprintf.php:252], referer: https://${MY_HOST}/applications/
  #0 _qsprintf_check_type(array, string, string) called at [<phutil>/src/xsprintf/qsprintf.php:129], referer: https://${MY_HOST}/applications/
  #1 xsprintf_query(AphrontMySQLiDatabaseConnection, string, integer, array, integer) called at [<phutil>/src/xsprintf/xsprintf.php:69], referer: https://${MY_HOST}/applications/
  #2 xsprintf(string, AphrontMySQLiDatabaseConnection, array) called at [<phutil>/src/xsprintf/qsprintf.php:64], referer: https://${MY_HOST}/applications/
  #3 qsprintf(AphrontMySQLiDatabaseConnection, string, array) called at [<phabricator>/src/applications/project/query/PhabricatorProjectQuery.php:270], referer: https://${MY_HOST}/applications/
  #4 PhabricatorProjectQuery::buildWhereClause(AphrontMySQLiDatabaseConnection) called at [<phabricator>/src/applications/project/query/PhabricatorProjectQuery.php:130], referer: https://${MY_HOST}/applications/
  #5 PhabricatorProjectQuery::loadPage() called at [<phabricator>/src/infrastructure/query/policy/PhabricatorPolicyAwareQuery.php:227], referer: https://${MY_HOST}/applications/
  #6 PhabricatorPolicyAwareQuery::execute() called at [<sprint>/controller/SprintListController.php:67], referer: https://${MY_HOST}/applications/
  #7 SprintListController::loadAllSprints(PhabricatorUser, array) called at [<sprint>/controller/SprintListController.php:16], referer: https://${MY_HOST}/applications/
  #8 SprintListController::processRequest() called at [<phabricator>/src/aphront/AphrontController.php:33], referer: https://${MY_HOST}/applications/
  #9 AphrontController::handleRequest(AphrontRequest) called at [<phabricator>/src/aphront/configuration/AphrontApplicationConfiguration.php:196], referer: https://${MY_HOST}/applications/
  #10 AphrontApplicationConfiguration::processRequest(AphrontRequest, PhutilDeferredLog, AphrontPHPHTTPSink) called at [<phabricator>/src/aphront/configuration/AphrontApplicationConfiguration.php:121], referer: https://${MY_HOST}/applications/
  #11 AphrontApplicationConfiguration::runHTTPRequest(AphrontPHPHTTPSink) called at [<phabricator>/webroot/index.php:19], referer: https://${MY_HOST}/applications/

I installed the extension by adding it to load-libraries in local.json.

Phabricator Version: cdd8dcbf17bb4700cf22937ce0f3db43126ee5f3
Arcanist Version: 59640f7eae3f7c0a352c18e784fb55acb7967991
libphutil Version: 2b23ac46a8473304b68afa16c353539e18e2e9f4
The sprint extension is at: 24d59c2fd10eec0ad8251ab26e4fb8f1eb345d97

Event Timeline

devurandom raised the priority of this task from to Needs Triage.
devurandom updated the task description. (Show Details)
devurandom added a subscriber: devurandom.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 9 2015, 5:39 PM

P.S: I clicked the "Sprint" application in the Applications list to get to that URL.

the problem is because there were no sprints created yet, and there was no exception handler for this. It has been fixed in 4e90abfee937d8e3d67129b204d02f6178985e0b

Christopher closed this task as Resolved.Feb 10 2015, 6:27 PM
Christopher set Security to None.
Christopher edited a custom field.