Page MenuHomePhabricator

Grants for my Tools-db missing to insert new lines
Closed, ResolvedPublic

Description

In my project Templatetiger I had in the past rights to change to db. These seems missing now:

 MariaDB [s51071__templatetiger_p]> SHOW GRANTS FOR CURRENT_USER;
+-----------------------------------------------------------------------------------------------------------+
| Grants for s51071@%                                                                                       |
+-----------------------------------------------------------------------------------------------------------+
| GRANT SHOW VIEW ON *.* TO 's51071'@'%' IDENTIFIED BY PASSWORD '*8B9D50D7AC8B053001A2050BB391233F5B8FD3B6' |
| GRANT ALL PRIVILEGES ON `s51071__%`.* TO 's51071'@'%' WITH GRANT OPTION                                   |
| GRANT SELECT, SHOW VIEW ON `%_p`.* TO 's51071'@'%'                                                        |

If I try to insert data, nothing happen. I can drop a table but this still exist:

MariaDB [s51071__templatetiger_p]> DROP TABLE `alswiki_neu`;
Query OK, 0 rows affected (0.00 sec)

MariaDB [s51071__templatetiger_p]> show tables like 'als%';
+------------------------------------------+
| Tables_in_s51071__templatetiger_p (als%) |
+------------------------------------------+
| alswiki_neu                              |
+------------------------------------------+
1 row in set (0.00 sec)

It's a miracle for me.

Event Timeline

Kolossos created this task.May 11 2015, 9:43 PM
Kolossos raised the priority of this task from to High.
Kolossos updated the task description. (Show Details)
Kolossos added a project: Toolforge.
Kolossos added a subscriber: Kolossos.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2015, 9:43 PM
scfc assigned this task to Springle.May 12 2015, 12:18 AM
scfc added a subscriber: scfc.
scfc moved this task from Triage to Backlog on the Toolforge board.May 12 2015, 3:30 AM

Afaik labs grants are set by @coren's maintain-replicas.pl, or perhaps @yuvipanda was rebuilding it? You'll need to ask them if anything has changed.

Springle removed Springle as the assignee of this task.May 12 2015, 9:27 AM
Springle set Security to None.
coren added a subscriber: Springle.EditedMay 23 2015, 3:31 PM

@Springle: The rights are correct, and indeed even dbmanager that has grant all privileges is unable to drop the table(s). The DROP statement just fails quietly but the table remains.

(That is, the issue isn't that Kolossos doesn't have the rights to drop the table, but that the table quietly remains when one drops them).

Ping? The problem still exist.

Restricted Application added a project: Cloud-Services. · View Herald TranscriptJul 25 2015, 8:27 PM
scfc added a subscriber: jcrespo.Jul 25 2015, 9:13 PM

@jcrespo, could you please take a look at this?

I repaired the table, made a backup on my home dir and dropped the table. The table may have originally corruption, as it had some strange behaviour. I can reimport the table if needed.

The grants are not a problem here, assuming the right user is being used. Does this solve your issues, @Kolossos ?

Kolossos closed this task as Resolved.Jul 27 2015, 7:15 PM
Kolossos claimed this task.

Thanks, it seems to work.