Page MenuHomePhabricator

Regression: Citoid crashes when getting internal server error for Zotero web translate
Closed, InvalidPublic

Description

https://www.google.co.uk/search?tbm=bks&hl=en&q=isbn%3A0596554141
/home/marielle/Code/Node/citoid/lib/CitoidRequest.js:17
	this.logger = app.logger;
	                 ^
TypeError: Cannot read property 'logger' of undefined
    at new CitoidRequest (/home/marielle/Code/Node/citoid/lib/CitoidRequest.js:17:19)
    at Suite.<anonymous> (/home/marielle/Code/Node/citoid/test/features/errors/export.js:9:11)
    at context.describe.context.context (/home/marielle/Code/Node/citoid/node_modules/mocha/lib/interfaces/bdd.js:49:10)
    at Object.<anonymous> (/home/marielle/Code/Node/citoid/test/features/errors/export.js:3:1)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at /home/marielle/Code/Node/citoid/node_modules/mocha/lib/mocha.js:192:27
    at Array.forEach (native)
    at Mocha.loadFiles (/home/marielle/Code/Node/citoid/node_modules/mocha/lib/mocha.js:189:14)
    at Mocha.run (/home/marielle/Code/Node/citoid/node_modules/mocha/lib/mocha.js:422:31)
    at Object.<anonymous> (/home/marielle/Code/Node/citoid/node_modules/mocha/bin/_mocha:398:16)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:902:3

Event Timeline

Mvolz created this task.Jun 16 2015, 10:28 AM
Mvolz claimed this task.
Mvolz raised the priority of this task from to Unbreak Now!.
Mvolz updated the task description. (Show Details)
Mvolz added a project: Citoid.
Mvolz moved this task to Service on the Citoid board.
Mvolz added a subscriber: Mvolz.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 16 2015, 10:28 AM
Mvolz renamed this task from Regression: Internal server error for Zotero web translate crashes citoid to Regression: Citoid crashes when getting internal server error for Zotero web translate.Jun 16 2015, 10:29 AM
Mvolz set Security to None.

Change 218605 had a related patch set uploaded (by Mvolz):
[WIP] Fix crashes caused by 500 Zotero response

https://gerrit.wikimedia.org/r/218605

Mvolz closed this task as Invalid.Jun 16 2015, 10:56 AM
Mvolz removed a project: Patch-For-Review.

Closing as invalid, was caused by local issues :).