iridium (phab server) - Could not find dependency Package[php5]
Closed, ResolvedPublic

Description

On Host
iridium

Current Status:	
  CRITICAL  
 (for 1d 1h 14m 2s)
Status Information:	CRITICAL: puppet fail

--

Error: Failed to apply catalog: Could not find dependency Package[php5] for File[/etc/php5/apache2/php.ini] at /etc/puppet/modules/phabricator/manifests/init.pp:249
Dzahn created this task.Jul 8 2015, 6:30 PM
Dzahn updated the task description. (Show Details)
Dzahn raised the priority of this task from to Needs Triage.
Dzahn added a subscriber: Dzahn.
Restricted Application added subscribers: Matanya, scfc, Aklapper. · View Herald TranscriptJul 8 2015, 6:30 PM
Dzahn set Security to None.Jul 8 2015, 6:30 PM
Dzahn added subscribers: chasemp, 20after4.

Change 223701 had a related patch set uploaded (by Negative24):
Remove php5 dependency check

https://gerrit.wikimedia.org/r/223701

Negative24 updated the task description. (Show Details)Jul 8 2015, 11:48 PM
Dzahn added a comment.Jul 8 2015, 11:55 PM

16:52 < mutante> Negative24: i think it should depend more on libapache2-mod-php5
16:53 < mutante> since it's file { '/etc/php5/apache2/php.ini'
16:53 < mutante> no?
16:53 < Negative24> yea
16:55 < mutante> so we get that from include apache::mod::php5

Dzahn closed this task as Resolved.Jul 9 2015, 12:08 AM
Dzahn claimed this task.

https://gerrit.wikimedia.org/r/#/c/223701/7/modules/phabricator/manifests/init.pp


Info: Applying configuration version '1436400170'
...
Notice: Finished catalog run in 195.81 seconds


17:08 < icinga-wm> RECOVERY - puppet last run on iridium is OK Puppet is currently enabled, last run 26 seconds ago with 0 failures