Page MenuHomePhabricator

deployment-bastion fails puppet because some classes were moved from nodes to role class
Closed, ResolvedPublic

Description

Puppet has been falling since July 7th with two issues:

Error: Could not start Service[bacula-fd]: Execution of '/etc/init.d/bacula-fd start' returned 1: 
Error: /Stage[main]/Bacula::Client/Service[bacula-fd]/ensure:
           change from stopped to running failed: Could not start Service[bacula-fd]:
               Execution of '/etc/init.d/bacula-fd start' returned 1:

Caused by https://gerrit.wikimedia.org/r/#/c/223448/ which moved the role::backup::host from nodes to role::deployment::server which is applied on labs.

FIX: https://gerrit.wikimedia.org/r/225023

Error: /Stage[main]/Releases::Reprepro::Upload/File[/var/lib/releases/.ssh/id_rsa.caesium.eqiad.wmnet]:
           Could not evaluate: Could not retrieve information from environment production source(s) puppet:///private/releases/id_rsa.upload

Caused by https://gerrit.wikimedia.org/r/#/c/223464/ which moved the role::releases::upload class from tin to role::deployment::server.

FIX: https://gerrit.wikimedia.org/r/225025

Event Timeline

hashar created this task.Jul 16 2015, 10:22 AM
hashar raised the priority of this task from to Needs Triage.
hashar updated the task description. (Show Details)
hashar added subscribers: hashar, Dzahn.
Restricted Application added subscribers: Luke081515, Matanya, Aklapper. · View Herald TranscriptJul 16 2015, 10:22 AM

Change 225023 had a related patch set uploaded (by Hashar):
Do not backup beta cluster deployment server

https://gerrit.wikimedia.org/r/225023

Did some cleanup based on /var/log/apt/history.log

Start-Date: 2015-07-07  22:35:01
Commandline: /usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install bacula-fd
Install: bacula-common:amd64 (5.2.5-0ubuntu6.2, automatic), liblzo2-2:amd64 (2.06-1ubuntu0.1, automatic), bacula-fd:amd64 (5.2.5-0ubuntu6.2)
End-Date: 2015-07-07  22:35:06
hashar updated the task description. (Show Details)Jul 16 2015, 10:30 AM
hashar set Security to None.
hashar renamed this task from deployment-bastion fails puppet because of bacula to deployment-bastion fails puppet because some classes were moved from nodes to role class.Jul 16 2015, 10:33 AM
hashar updated the task description. (Show Details)

Change 225025 had a related patch set uploaded (by Hashar):
Do not use releases::upload on beta cluster deployment server

https://gerrit.wikimedia.org/r/225025

hashar claimed this task.Jul 16 2015, 10:38 AM
hashar updated the task description. (Show Details)
hashar triaged this task as Normal priority.Jul 16 2015, 10:41 AM

I have cherry picked both patches on beta cluster puppetmaster and puppet now passes on deployment-bastion.

Change 225023 merged by Dzahn:
Do not backup beta cluster deployment server

https://gerrit.wikimedia.org/r/225023

Change 225025 merged by Dzahn:
Do not use releases::upload on beta cluster deployment server

https://gerrit.wikimedia.org/r/225025

hashar closed this task as Resolved.Jul 17 2015, 10:02 AM

Beta cluster puppetmaster rebased just fine and puppet pass on deployment-bastion. Danke @Dzahn