Page MenuHomePhabricator

Cannot login to Huggle 3.1.14
Closed, ResolvedPublic

Description

I downloaded Huggle 3.1.14 for Mac OS X from GitHub today and received the following error while attempting to login. Repeated attempts produced the same error.

System log

Sun Jul 19 17:47:01 2015: Loaded in 219ms
Sun Jul 19 17:47:01 2015: Extensions: 4
Sun Jul 19 17:47:01 2015: Successfully loaded: /Applications/huggle.app/Contents/MacOS/../PlugIns/libhuggle_thanks.dylib
Sun Jul 19 17:47:01 2015: Successfully loaded: /Applications/huggle.app/Contents/MacOS/../PlugIns/libhuggle_sh.dylib
Sun Jul 19 17:47:01 2015: Successfully loaded: /Applications/huggle.app/Contents/MacOS/../PlugIns/libhuggle_md.dylib
Sun Jul 19 17:47:01 2015: Successfully loaded: /Applications/huggle.app/Contents/MacOS/../PlugIns/libhuggle_en.dylib
Sun Jul 19 17:47:01 2015: Loading plugins in /Applications/huggle.app/Contents/MacOS/../PlugIns and /Users/mj94/Library/Application Support/Wikimedia/Huggle/extensions/
Sun Jul 19 17:47:01 2015: Home: /Users/mj94/Library/Application Support/Wikimedia/Huggle
Sun Jul 19 17:47:01 2015: Loading configuration
Sun Jul 19 17:47:01 2015: Huggle 3 QT-LX, version 3.1.13 build: 2597 3.1.14

Exception details

Error code: 2
Reason: There is no data to be processed
Source: void Huggle::ApiQueryResult::Process()@/Users/petanb/Documents/huggle3-qt-lx/huggle/apiqueryresult.cpp:89
Stack trace:
Stack trace not available for this OS

Event Timeline

MJ94 created this task.Jul 19 2015, 10:55 PM
MJ94 updated the task description. (Show Details)
MJ94 raised the priority of this task from to Needs Triage.
MJ94 added a project: Huggle.
MJ94 added a subscriber: MJ94.
Restricted Application added subscribers: Josve05a, Luke081515, Aklapper. · View Herald TranscriptJul 19 2015, 10:55 PM
MJ94 triaged this task as Unbreak Now! priority.Jul 20 2015, 12:22 AM

Unable to reproduce on my end (yet)

Version: 3.1.13 build: 2597 3.1.14 without python support, compiled using QT 5.4.1 Running on QT 5.4.1

P.S. Do we have a version number out of date somewhere? Or am I testing on the wrong build?

Petrb added a subscriber: Petrb.Jul 20 2015, 3:00 PM

Looks that version number is wrong. Did previous version work ok?

MJ94 added a comment.Jul 21 2015, 1:36 AM

In case there's any confusion, I used the Huggle (3.1.14) for Mac OS X link found on the Huggle download page. It is the fourth one down and a direct link can be found here. I removed Huggle from my system and downloaded it again to confirm that I am still receiving an error, which I am.

Petrb added a comment.Jul 21 2015, 7:18 AM

Did you ever use any other version of huggle on this OS which worked?

Petrb added a comment.Jul 21 2015, 7:19 AM

The problem here is that huggle can't download stuff using internet, OS is somehow blocking its network access it seems.

MJ94 added a comment.Jul 21 2015, 8:19 AM

Yes, I have used previous versions of Huggle on this operating system and computer. I haven't used Huggle for quite some time, but I know that I haven't set anything to block it on purpose. Perhaps a security setting on OS X is blocking it by default? I am not sure.

Petrb added a comment.Jul 21 2015, 8:45 AM

Can you try install some of the previous versions? Do they work now?

Petrb added a comment.Jul 21 2015, 2:08 PM

Keep in mind that you must use SSL since now

MJ94 added a comment.Jul 22 2015, 4:56 AM

If I check "Use HTTPS (requires OpenSSL)" I am able to login just fine; however, if I do not check it, I receive the error posted above. Out of curiosity, if SSL is required (and not using SSL produces errors), why are users given the option to choose whether to use HTTPS or not?

Petrb added a comment.Jul 22 2015, 7:41 AM

They are not, if you wipe you config it will no longer allow you, it's
recent change of config that forbid users from using non ssl on WMF
servers. You still have configuration from previous time when it was
possible.

Petrb added a comment.Jul 22 2015, 7:41 AM
This comment was removed by Petrb.
Petrb closed this task as Resolved.Jul 22 2015, 7:42 AM
Petrb claimed this task.