Embedded video player broken
Closed, ResolvedPublic

Description

Example: https://commons.wikimedia.org/wiki/File%3ACuriosity%27s_Seven_Minutes_of_Terror.ogv?embedplayer=yes

JS errs include:

ReferenceError: mw is not defined
"TypeError: mw.mergeConfig is not a function"
Error: Error loading EmbedPlayer dependency set: One or more dependencies failed to load

Might be a regression related to ogv.js merge. :(

brion created this task.Aug 7 2015, 6:25 PM
brion updated the task description. (Show Details)
brion raised the priority of this task from to Needs Triage.
brion claimed this task.
brion added a subscriber: brion.
Restricted Application added a project: Multimedia. · View Herald TranscriptAug 7 2015, 6:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
brion added a comment.Aug 7 2015, 6:30 PM

Looks more like a core JS/RL change... startup script is now loaded asynchronously, which breaks all the scripts in the embed player that attempt to use mw synchronously. :P

Restricted Application added a subscriber: Matanya. · View Herald TranscriptAug 7 2015, 6:30 PM

Change 230151 had a related patch set uploaded (by Brion VIBBER):
Fix regression in iframe embedding for MediaWiki core updates

https://gerrit.wikimedia.org/r/230151

Change 230151 merged by jenkins-bot:
Fix regression in iframe embedding for MediaWiki core updates

https://gerrit.wikimedia.org/r/230151

Change 230656 had a related patch set uploaded (by Jforrester):
Fix regression in iframe embedding for MediaWiki core updates

https://gerrit.wikimedia.org/r/230656

Change 230656 merged by jenkins-bot:
Fix regression in iframe embedding for MediaWiki core updates

https://gerrit.wikimedia.org/r/230656

I don't think that fully fixed it

Hmm... it works in debug mode https://commons.wikimedia.org/wiki/File%3ACuriosity%27s_Seven_Minutes_of_Terror.ogv?embedplayer=yes&debug=yes but not without; something getting loaded out of order perhaps.

Was there time to analyze this further?

Jdforrester-WMF moved this task from Untriaged to Doing on the Multimedia board.Sep 4 2015, 6:52 PM
Jdforrester-WMF triaged this task as Unbreak Now! priority.
Jdforrester-WMF set Security to None.
Jdforrester-WMF moved this task from Doing to Done on the Multimedia board.Sep 8 2015, 3:38 PM
brion added a comment.Sep 8 2015, 6:39 PM

Definitely still broken:

Exception in module-execute in module mw.MediaSource:
load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:177 TypeError: mw.mergeConfig is not a function TypeError: mw.mergeConfig is not a function(…)log @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:177handler @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:155jQuery.Callbacks.fire @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:45jQuery.Callbacks.self.fireWith @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:46jQuery.Callbacks.self.fire @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:46mw.track @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:155runScript @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:163mw.loader.checkCssHandles @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:163execute @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:164mw.loader.modules.implement @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:170(anonymous function) @ VM175:140(anonymous function) @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:4jQuery.extend.globalEval @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:4mw.loader.modules.work @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:166request @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:164mw.loader.modules.load @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:171(anonymous function) @ File%3ACuriosity's_Seven_Minutes_of_Terror.ogv?embedplayer=yes:66startUp @ load.php?debug=false&lang=en&modules=startup&only=scripts&skin=vector:66script.onload.script.onreadystatechange @ load.php?debug=false&lang=en&modules=startup&only=scripts&skin=vector:67
load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:177 Exception in load-callback in module mw.MwEmbedSupport:
load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=Kk41yJbu:177 Error: Error loading EmbedPlayer dependency set: One or more dependencies failed to load Error: Error loading EmbedPlayer dependency set: One or more dependencies failed to load(…)

Change 236858 had a related patch set uploaded (by Brion VIBBER):
Another hack at fixing embed player

https://gerrit.wikimedia.org/r/236858

Change 236858 merged by jenkins-bot:
Another hack at fixing embed player

https://gerrit.wikimedia.org/r/236858

Krenair moved this task from Done to Needs code review on the Multimedia board.Sep 8 2015, 7:46 PM
MarkTraceur moved this task from Needs code review to Done on the Multimedia board.Sep 9 2015, 3:32 PM
brion added a comment.Sep 9 2015, 3:35 PM

Ok this is merged since yesterday; should go out with next weeks updates as usual or we can SWAT it if we're in a hurry.

Jdforrester-WMF closed this task as Resolved.Sep 11 2015, 6:13 PM