Page MenuHomePhabricator

Safari rendering issues with notification feature in toolbar
Closed, DuplicatePublic

Description

On Commons using Safari 8.0.8 I see broken HTML rendering as if partially transparent versions of the Alerts/Messages boxes are overlaying pages (i.e. transparent broken versions of the notification boxes that normally open when you click their icon in the toolbar). Interestingly this only started happening today (Sep 14), does not happen on en.WP, and does not happen in either Firefox or Chrome. It does happen on multiple machines, so it doesn't appear to be a cache or machine-specific issue. I don't see the issue if I am not logged in, but that is presumably because logged out users don't have the alert/message icons.

It's possible this is related to https://gerrit.wikimedia.org/r/#/c/238160/1

See https://commons.wikimedia.org/wiki/Commons:Village_pump#HTML_rendering_issues_with_notifications_in_toolbar

Bug is also reported to occur in mobile Safari (presumably in "desktop" layout).

Event Timeline

RP88 created this task.Sep 14 2015, 9:44 PM
RP88 raised the priority of this task from to Needs Triage.
RP88 updated the task description. (Show Details)
RP88 added a subscriber: RP88.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 14 2015, 9:44 PM
RP88 updated the task description. (Show Details)Sep 14 2015, 9:45 PM
RP88 set Security to None.
RP88 updated the task description. (Show Details)
RP88 updated the task description. (Show Details)Sep 14 2015, 9:51 PM