Page MenuHomePhabricator

ContactPage Catchable fatal error (due to ConfirmEdit/ReCaptcha/QuestyCaptcha incompatibility?)
Closed, ResolvedPublic

Description

Installed:

MediaWiki 1.26.2
PHP 5.3.29 (apache2handler)
MySQL 5.0.95
ConfirmEdit 1.4.0
ContactPage 2.2
Semantic Maps 3.2
Semantic MediaWiki 2.3

I'm a bit confused by the following:

My contact form works fine when logged in. But when not logged in, I get

Catchable fatal error: Argument 1 passed to QuestyCaptcha::getForm() must be an instance of OutputPage, none given, called in /www/htdocs/drebbel/wiki/extensions/ContactPage/ContactPage_body.php on line 433 and defined in /www/htdocs/drebbel/wiki/extensions/ConfirmEdit/QuestyCaptcha/QuestyCaptcha.class.php on line 44


My LocalSettings.php:

require_once( "$IP/extensions/ConfirmEdit/ConfirmEdit.php" );

require_once( "$IP/extensions/ConfirmEdit/QuestyCaptcha.php");

$wgCaptchaClass = 'QuestyCaptcha';

require_once "$IP/extensions/ContactPage/ContactPage.php";

$wgCaptchaTriggers['contactpage'] = true;

$wgContactConfig['default'] = array(

'RecipientUser' => 'xxxx', // a valid account which also has a verified e-mail-address added to it.

'SenderName' => 'Contact Form on ' . $wgSitename, // "Contact Form on" needs to be translated

'SenderEmail' => null, // Defaults to $wgPasswordSender, may be changed as required

'RequireDetails' => true, // Either "true" or "false" as required

'IncludeIP' => true, // Either "true" or "false" as required

'AdditionalFields' => array(

'Text' => array(

'label-message' => 'emailmessage',

'type' => 'textarea',

'rows' => 20,

'cols' => 80,

'required' => true, // Either "true" or "false" as required

),

),

// Added in MW 1.26

'DisplayFormat' => 'table',  // See HTMLForm documentation for available values.

'RLModules' => array(),  // Resource loader modules to add to the form display page.

'RLStyleModules' => array(),  // Resource loader CSS modules to add to the form display page.

);


If I change $wgContactConfig['default'] = array( into $wgContactConfig['contactpage'] = array( , I get

Contact form error
A contact form is either not configured for this page or is configured incorrectly.

Event Timeline

EFFemeer created this task.Dec 25 2015, 2:03 PM
EFFemeer updated the task description. (Show Details)
EFFemeer raised the priority of this task from to Needs Triage.
EFFemeer added a subscriber: EFFemeer.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 25 2015, 2:03 PM

Has this also been brought up on https://www.mediawiki.org/wiki/Project:Support_desk already? Is this a fresh installation or an upgrade?
Does this also happen when using the ContactPage REL1_26 branch from git instead of the two year old 2.2 version?

It has been brought up 10 days ago in https://www.mediawiki.org/wiki/Extension_talk:ContactPage
My wiki has been upgraded regularly. I started using Composer (on my Windows laptop) about a month ago (and ran into several problems since then). And the problem occurs with the package taken from the Git Rel1-26.

Via https://www.mediawiki.org/w/index.php?title=Topic:Sw39iixi0k8h2k0z&topic_showPostId=sw3cedhegj16cg45&fromnotif=1#flow-post-sw3cedhegj16cg45

I got the reaction that : The code of the ReCaptcha plugin and of the ContactPage extension are not compatible currently.

Aklapper renamed this task from ContactPage Catchable fatal error to ContactPage Catchable fatal error (due to ConfirmEdit/ReCaptcha/QuestyCaptcha incompatibility?).Jan 8 2016, 8:30 PM
Aklapper set Security to None.

Change 263323 had a related patch set uploaded (by Florianschmidtwelzow):
Fix getForm() call to get CAPTCHA from ConfirmEdit

https://gerrit.wikimedia.org/r/263323

Change 263323 merged by jenkins-bot:
Fix getForm() call to get CAPTCHA from ConfirmEdit

https://gerrit.wikimedia.org/r/263323

Florian closed this task as Resolved.Jan 11 2016, 2:55 PM
Florian claimed this task.

Thanks for your assistance, Florian and André.