Page MenuHomePhabricator

rctype (list=recentchanges) should use words rather than numbers
Closed, ResolvedPublic


Currently, list=recentchanges returns rctype="0" for normal edits, rctype="1" for page creations, and rctype="3" for log messages (types 2 and 4 being deprecated and unused (AFAIK) numbers for page moves and moves over redirect respectively). For clarity, future-proofness and all that good stuff, the numbers should be changed to words that resemble the constants in Defines.php:


  • RecentChange type identifiers
  • This may be obsolete; log items are now used for moves? */

define( 'RC_EDIT', 0);
define( 'RC_NEW', 1);
define( 'RC_MOVE', 2);
define( 'RC_LOG', 3);
define( 'RC_MOVE_OVER_REDIRECT', 4);

I would like to suggest type="edit" for type="0", type="new" for type="1" and type="log" for type="3". For safety (wikis upgraded from a very old version to 1.12 or wikis with very a long $wgRCMaxAge) type="move" (2) and type="move over redirect" (4) should also be added.

Version: 1.12.x
Severity: minor



Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 9:57 PM
bzimport set Reference to bz11632.
bzimport added a subscriber: Unknown Object (MLST).

cannon.danielc wrote:

Committed as r26615.