Page MenuHomePhabricator

Enable sorting of interwiki links in Wikibase Client
Closed, ResolvedPublic

Description

Right now, and for quite a while, interwiki links on English Wikipedia's Main Page are sorted incorrectly: Bahasa Indonesia and Basa Jawa are sorted under B while they should be under I and J.

It is possible to sort the links manually (at Template:Main Page interwikis), however since the interwiki bots are used very rarely now, this could easily become unsorted again when a new language is added. Then, there is a question of how the links are sorted on other Wikipedias etc.

So, I suggest that alwaysSort option is returned to Wikibase Client, or to introduce a new magic word, for example {{sortinterlanguagelinks}} that would sort the links.

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptJul 2 2016, 8:23 AM
Restricted Application added subscribers: Zppix, Aklapper. · View Herald Transcript
aude added a subscriber: aude.Nov 24 2016, 9:09 PM
thiemowmde closed this task as Invalid.Feb 28 2018, 7:37 PM
thiemowmde added a subscriber: thiemowmde.

To clean our backlogs I'm going to close this for now, for the following reasons:

  • I don't see a problem on https://en.wikipedia.org/wiki/Main_Page.
  • Interwiki links on the clients are already sorted. Therefore I wonder what "enable sorting" refers to. The code was previously in the Wikibase code base, and recently moved to MediaWiki-extensions-InterwikiSorting. Is there an issue with that?
  • I don't want us to maintain an other parser function for a rare edge-case like this. Different requirements for the order should be configuration per wiki, and already are as far as I'm aware of.

If the issue is still there, please provide more information and feel free to reopen this ticket.

Nikola_Smolenski changed the task status from Invalid to Resolved.Feb 28 2018, 9:13 PM

I don't know who, how and when, but this is fixed, in fact.