Page MenuHomePhabricator

Lack of an unused redirects list
Closed, ResolvedPublic

Description

Is there any way we could get an unused redirects list? I know ENWP does something similar and Wikia can do it as well. ENWP uses a bot to create their list, but perhaps there is some way for a special page to be created?

Event Timeline

lcf119 created this task.Aug 29 2016, 10:12 PM

RFC @ashley So on the wikia forum it shows the DPL extension being used, could you consider testing that and installing it and maybe see if that works, or if you can think of any other (and possibly more efficient) solutions?

DPL

There are very few questions for which DPL is the appropriate answer. This is not such a question.

One of the many concerns related to the DPL extension is performance. This is better done as a QueryPage, like the core Special:Unused* pages. I've written such an extension, which adds a Special:UnusedRedirects page. Obviously it could use a bit more testing, but based on some quick tests on my local dev wiki, it seems to be working as intended.
I've filed a request for a new git repo for publishing the source code; I'm not sure how to properly add it as a git submodule for the Brickimedia/extensions repository, but we can deploy it to production without that and have someone more git-savvy clean it up at a later date.

Change 308323 had a related patch set uploaded (by Jack Phoenix):
Initial commit of a new extension

https://gerrit.wikimedia.org/r/308323

Change 308323 merged by Jack Phoenix:
Initial commit of a new extension

https://gerrit.wikimedia.org/r/308323

patch has been reviewed and merged by @ashley

ashley closed this task as Resolved.Sep 29 2016, 5:56 PM
ashley claimed this task.

So I've deployed the UnusedRedirects extension (globally), albeit in a slightly unorthodox way, and after a query fix and running maintenance/updateSpecialPages.php to update the data (on en), the special page is now displaying data.