Page MenuHomePhabricator

Create new namespace "Course" in MOOC extension
Closed, DeclinedPublic

Description

Create new namespace Course for courses, for wikiversity. This would be somewhat similar to Extension:Category, in that it allows individual wiki pages to be added to a Course, with several key differences:

  1. Pages in a Course could be manually ordered. (Category sorts all pages by alphabetical order only.)
  2. Users could "Join" a Course. Doing so would add all the pages of the course to a special Courses user page.
  3. Users could mark individual pages of a Course as 'complete', or 'skip' to remove the page from their Courses page
  4. Another page might keep a record all of their completed work
    • The master page would have a list of all completed pages
    • Perhaps they would have a copy (?) of each course page, with a page next to it to write down their answers/record their work, like a Talk or Sandbox page?

This is also somewhat similar to wikisources various Book templates. However, this can't be done in a template or a gadget because it requires access to the database to store a user's progress through a course. It is also somewhat similar to watchlist; it's possible that a special gadget could made to convert the watchlist into a course subscription UI instead. However, this would prevent the user of the gadget from using watchlist for its original intention.

It's not clear how this would interact with the Quiz extension. At present, it is not possible for a user to save their quiz results either. However, in the future it would be nice for quiz results to be stored and also be marked as completed in a user's special Courses page.

Other functionality may have to do with timing or scheduling of a course. As currently described, this feature would work best if a course is gone through at the user's own pace. However, it is may be desirable in the future to "run" a course during a certain time period, or have certain lessons be "due" at certain times. Or have courses that are intended to be gone through with daily work, or weekly work, etc. This is possibly complicated permissions-wise; perhaps we could need a "course owner" role.

For discussion, see: https://en.wikiversity.org/wiki/Wikiversity:Colloquium#Software.2Fextension_to_increase_functionality_of_courses

Event Timeline

Mvolz created this task.Sep 22 2016, 1:46 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 22 2016, 1:46 PM
Mvolz updated the task description. (Show Details)Sep 22 2016, 1:55 PM
Mvolz added a comment.Sep 26 2016, 6:46 PM

Possible dupe of T111630?

The MOOC extension that is currently under development will add the 'Course' namespace to the MediaWiki. However, we could change that if someone else is using this namespace meanwhile.

Mvolz renamed this task from Create new namespace "Course" in MOOC extension or create new Extension:Course to Create new namespace "Course" in MOOC extension.Oct 14 2016, 1:46 PM

@Mvolz, would you like to add this list to possible projects for Outreachy/GSoC for May-Aug 2017? Please add Outreach-Programs-Projects tag if so.

@Mvolz I am interested in working on this project, would this be suitable for GSOC 2017 if so I would like to write a proposal for this??

Mvolz added a comment.Mar 24 2017, 4:57 PM

@DeeOladipo unfortunately I don't think this would be a good project for this round as I'm not sure the MOOC extension is mature enough or perhaps may already be working on this. Maybe @Sebschlicht would have more information though.

srishakatux added a subscriber: srishakatux.

Removing the Possible-Tech-Projects tag as we are planning to kill it soon! This project does not seem to fit in the Outreach-Programs-Projects category in its current state, so I am not adding that tag right now!

Zoranzoki21 closed this task as Declined.Dec 31 2018, 7:10 AM
Zoranzoki21 added a subscriber: Zoranzoki21.

Closing as declined because of archival per T202803.