Page MenuHomePhabricator

pages tag doesn't include the first page
Closed, DeclinedPublic

Description

Using the pages tag at https://de.wikisource.org/w/index.php?title=Was_will_das_werden%3F&oldid=2853772
produce a false view. You can see, that the first page of every pages tag isn't included.

Event Timeline

THE_IT created this task.Sep 23 2016, 9:44 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2016, 9:44 AM

@THE_IT see: echnische Neuerung, die eventuell zu Problemen führt

<pages index="Die Gartenlaube (1886)" from="Die Gartenlaube (1886) 002.jpg" to="Die Gartenlaube (1886) 003.jpg" fromsection= tosection=/>

should be corrected to:

<pages index="Die Gartenlaube (1886)" from="Die Gartenlaube (1886) 002.jpg" to="Die Gartenlaube (1886) 003.jpg" fromsection="" tosection=""/>

or

<pages index="Die Gartenlaube (1886)" from="Die Gartenlaube (1886) 002.jpg" to="Die Gartenlaube (1886) 003.jpg" />
Tpt closed this task as Declined.Sep 24 2016, 7:55 AM
Tpt added a subscriber: Tpt.

This issue is caused by the fact that now tags <a b= c=></a> is parsed by MediaWiki parser as <a b="c="></a> and no more <a b="" c=""></a>. ProofreadPage can't do anything about it (except implement its own Wikitext parser but it's definitely not a good idea).

It has been done in order to have the same parsing behaviours as HTML 5. (see T89331). There was a specific task about it but I don't find it anymore.

Thanks for the explaination

Billinghurst moved this task from Backlog to Done on the ProofreadPage board.Mar 5 2017, 2:07 AM