Page MenuHomePhabricator

Refreshed: Header floats above content with wikitable in site notice
Closed, ResolvedPublic

Description

Because our wiki is on a wiki farm, we occasionally get a GlobalSiteNotice set, and it's usually just some text in {| class="wikitable ... which appears at the top of all pages. Class wikitable has a margin: 1em 0; which seems pretty benign. However, because it's the first element, it stacks all the way up to div#content-wrapper, giving it a margin too. This is all according to spec.

Unfortunately, this causes the header to float on top of the content (1em down, of course). I think the solution would be to create a new block formatting context for the content box, either by adding overflow:auto or display: inline-block to either of #wikipage-content or #site-notice. Probably inline-block, because Refreshed isn't really targeting ancient browsers.

Event Timeline

labster created this task.Dec 12 2016, 3:22 AM
SamanthaNguyen moved this task from Backlog to Bugs on the Refreshed board.Dec 15 2016, 1:40 AM
SamanthaNguyen added projects: Design, CSS.

Change 354882 had a related patch set uploaded (by SamanthaNguyen; owner: SamanthaNguyen):
[mediawiki/skins/Refreshed@master] v3.2.0 - Fix #site-notice interaction with #header-wrapper

https://gerrit.wikimedia.org/r/354882

Change 354882 merged by jenkins-bot:
[mediawiki/skins/Refreshed@master] v3.2.0 - Fix #site-notice interaction with #header-wrapper

https://gerrit.wikimedia.org/r/354882

SamanthaNguyen closed this task as Resolved.May 21 2017, 4:40 PM
SamanthaNguyen moved this task from Incoming to Done on the Design board.
SamanthaNguyen removed a project: Patch-For-Review.
SamanthaNguyen removed a subscriber: gerritbot.
MacFan4000 reopened this task as Open.Oct 13 2017, 10:25 PM
MacFan4000 added a subscriber: MacFan4000.

It would seem that when anything is in the site notice, the header moves down a bit.

SamanthaNguyen closed this task as Resolved.Oct 14 2017, 4:07 AM

You can’t just reopen a task without providing any other context - please, again, spend time to provide info on your MediaWiki environment. I have already mentioned to you several times on what you need to include...

You also need to report this in a separate ticket, and then if with enough evidence that it’s a regression, then it can be tagged with Regression.

Everything is at the latest version. MW 1.29 etc.