Page MenuHomePhabricator

Audio/video playback fails in MS Edge in Windows 10 Insider build 15002
Closed, ResolvedPublic

Description

Edge in Windows 10 Insider build 15002 seems to have a bug that affects ogv.js's streaming input, causing requests for Ogg file chunks to fail. Specifically, the 'Range' request header is being incorrectly set on the CORS OPTIONS preflight request, which naturally returns a 416 "Range cannot be satisfied" error.

Result is that audio and video cannot be played back in Edge browser on the latest Windows Insider build...

Reported upstream: https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/10494718/

Event Timeline

brion created this task.Jan 11 2017, 5:24 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 11 2017, 5:24 AM
Paladox moved this task from Backlog to Reported Upstream on the Upstream board.Jan 11 2017, 9:27 AM

Still affected in build 15007, but bug report is listed as "In code review" upstream so it should make it in before the Windows 10 Creator Update hits final version. :)

brion added a comment.Feb 8 2017, 7:21 PM

Build 15031 fixes the immediate problem but still introduces some other incompatibility... however it seems to be worked around by the updated streaming code in ogv.js master. I'll prep an update release...

Change 336677 had a related patch set uploaded (by Brion VIBBER):
Update ogv.js to 1.3.0 (buffering, seeking, Win10 fixes)

https://gerrit.wikimedia.org/r/336677

Change 336677 merged by jenkins-bot:
Update ogv.js to 1.3.0 (buffering, seeking, Win10 fixes)

https://gerrit.wikimedia.org/r/336677

brion closed this task as Resolved.Feb 25 2017, 8:19 PM

Confirmed resolved with current Win10 Insider build and currently deployed version of ogv.js.