Logo missing on Swedish Wikipedia (sv.wikipedia) on certain zoom ranges/screen resolution
Closed, ResolvedPublic

Description

(Frrely translated by @Josve05a using Google Translate, from https://sv.wikipedia.org/wiki/Wikipedia:Wikipediafr%C3%A5gor#F.C3.B6rsvunnen_logga)

Since a few weeks back, the Wikipedia logo at the top left missing for me at smaller screens (13.3 "), on the large screen (17") however, it looks as usual. If I zoom out and view the page in less than 100% the logo pops up. Now on the edit-a-thon recently in Gothenburg, I discover that I am not alone in experiencing this. It just seems to be a problem on sv.wp and that is regardless of being logged in or not. Someone who knows what might have happened?

I see the same problem with the logo "disappearing" in a specific "zoom ranges" no matter if I use Microsoft Edge or Mozilla Firefox browser. When the elements of the code represent the <div id="p-logo" role="banner"></div> is less than 240 × 240 or larger than 300 × 300 the logo is visable as it should, but for sizes between (and including) 240 × 240 and 300 × 300, everything you see is an empty white box. Could possibly be due to the "renderings" of the login screen for these sizes have failed and the unsuccessful outcome lies in a cache somewhere on the way and will not be updated. Someone would then need to clear the cache. But this is only a guess.

The above-mentioned "div" contains the following code: <a class="mw-wiki-logo" href="https://sv.wikipedia.org/wiki/Portal:Huvudsida" title="Besök huvudsidan"></a>Maybe it's something with the class "mw-wiki-logo" which needs to be fixed.

Josve05a created this task.Feb 6 2017, 9:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 6 2017, 9:38 PM
Abbe98 added a subscriber: Abbe98.EditedFeb 6 2017, 10:06 PM

I'm able to reproduce this.

Change 336330 had a related patch set uploaded (by Platonides):
Show again svwiki logo between 1.5x and 2x zoom

https://gerrit.wikimedia.org/r/336330

The problem is that https://gerrit.wikimedia.org/r/#/c/328908/ used

'svwiki' => [ '1.5x' => '/static/images/project-logos/1.5x.png', '2x' => '/static/images/project-logos/svwiki-2x.png' ], //T150618

where it should have been

'svwiki' => [ '1.5x' => '/static/images/project-logos/svwiki-1.5x.png', '2x' => '/static/images/project-logos/svwiki-2x.png' ], //T150618

https://sv.wikipedia.org/static/images/project-logos/1.5x.png (404) vs https://sv.wikipedia.org/static/images/project-logos/svwiki-1.5x.png

Change 336330 fixes it

Dereckson moved this task from Working on to To deploy on the Wikimedia-Site-requests board.

Change 336330 merged by jenkins-bot:
Show again svwiki logo between 1.5x and 2x zoom

https://gerrit.wikimedia.org/r/336330

Mentioned in SAL (#wikimedia-operations) [2017-02-07T00:26:23Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Show again svwiki logo between 1.5x and 2x zoom (T157387) (duration: 00m 40s)

Dereckson closed this task as "Resolved".Feb 7 2017, 12:27 AM
Dereckson triaged this task as "High" priority.
Dereckson added a subscriber: Dereckson.

Thanks to @Platonides for the quick fix and to @Josve05a to have helped to test this.