Page MenuHomePhabricator

&ooui=1 is not preserved after Show preview is clicked
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Open a random page
  2. Edit source
  3. Add &ooui=1 to the url
  4. Click show preview

Current behavior:
OOUI design is switched back to old one after showing preview

Expected behavior:
User (or probably better gadget dev) sometimes need to know if some gadget will work after previewing a page

Note: Feel free to close this as not planned, because OOUI will be deployed soon and the &ooui=1 functionality will be removed after that.

Event Timeline

Dvorapa created this task.May 14 2017, 9:11 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 14 2017, 9:11 AM
matmarex claimed this task.May 15 2017, 6:22 PM
matmarex added a subscriber: matmarex.

This would be indeed convenient. Hopefully it'll be a simple change.

Change 353905 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] EditPage: Preserve &ooui=1 / &ooui=0 from URL after preview

https://gerrit.wikimedia.org/r/353905

Change 353905 merged by jenkins-bot:
[mediawiki/core@master] EditPage: Preserve &ooui=1 / &ooui=0 from URL after preview

https://gerrit.wikimedia.org/r/353905

matmarex closed this task as Resolved.May 16 2017, 3:47 AM

There are no regular deployments this week (due to several teams having offsite meetings, and pre-hackathon travels), so this will probably go live next week.