Page MenuHomePhabricator

New tickets are missing CustomerID
Closed, ResolvedPublic

Description

Since the maintenance upgrade/update on 31 May, all new incoming tickets are missing CustomerIDs.

Related Objects

StatusSubtypeAssignedTask
Resolvedakosiaris
Resolvedakosiaris

Event Timeline

Josve05a created this task.Jun 1 2017, 1:12 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 1 2017, 1:12 AM
pajz added a subscriber: pajz.Jun 1 2017, 1:27 AM

See https://bugs.otrs.org/show_bug.cgi?id=10691#c15, in short - as far as I can see -: They removed the automatic assignment of CustomerIDs for new tickets in 5.0.16, then re-introduced the functionality in 5.0.17, but ever since then it needs to be specifically enabled through PostMaster::NewTicket::AutoAssignCustomerIDForUnknownCustomers. We should probably do that, since we don't assign CustomerIDs manually anyway.

pajz added a subscriber: akosiaris.Jun 1 2017, 1:32 AM

I usually use the PeopleCustomer to quickly find duplicate tickets, or old tickets by the same customer, which is not possible without an assigned customer ID, so would also recommend turning that thing on

I verified by looking into the database that indeed tickets no longer have their customer_id field filled with data, which is something that used to work fine.

akosiaris added a comment.EditedJun 1 2017, 8:24 AM

From the changelog it looks like this new config item was added.

The related bug is https://bugs.otrs.org/show_bug.cgi?id=10691

2017-02-08 Follow-up fix for bug#10691: add new config setting PostMaster::NewTicket::AutoAssignCustomerIDForUnknownCustomers to control creation of tickets with unknown customers.

However the Default is Yes (per the upstream bug above). Confirmed via the admin interface, however it does not seem to work

Setting it explicitly to Yes however works! I've done so now and will leave it like this. Will report the bug upstream

akosiaris closed this task as Resolved.Jun 1 2017, 8:48 AM
akosiaris claimed this task.

Reported upstream in https://bugs.otrs.org/show_bug.cgi?id=10691#c23. Will leaving the setting explicitly set to Yes regardless. I think this can be resolved.

Scoopfinder added a subscriber: Scoopfinder.