Page MenuHomePhabricator

Invalid magic word 'cscore' when trying to rebuild LC with Contribution Scores
Closed, DeclinedPublic

Description

Version: 1.29 (REL1_29)
PHP: 5.6

After installing and enabling Contribution Scores, I tried rebuilding the localisation cache (php rebuildLocalisationCache.php), and got the following error. I assume it's something to do with Flow, but I can't confirm.

[6613fa89d01922b6942431b6] [no req]   MWException from line 336 of /srv/mediawiki/w/includes/MagicWord.php: Error: invalid magic word 'cscore'
Backtrace:
#0 /srv/mediawiki/w/includes/MagicWord.php(261): MagicWord->load(string)
#1 /srv/mediawiki/w/includes/parser/Parser.php(4858): MagicWord::get(string)
#2 /srv/mediawiki/w/extensions/ContributionScores/ContributionScores.php(49): Parser->setFunctionHook(string, string)
#3 [internal function]: efContributionScores_Setup(Parser)
#4 /srv/mediawiki/w/includes/Hooks.php(186): call_user_func_array(string, array)
#5 /srv/mediawiki/w/includes/parser/Parser.php(337): Hooks::run(string, array)
#6 [internal function]: Parser->firstCallInit()
#7 /srv/mediawiki/w/includes/StubObject.php(113): call_user_func_array(array, array)
#8 /srv/mediawiki/w/includes/StubObject.php(139): StubObject->_call(string, array)
#9 /srv/mediawiki/w/includes/cache/MessageCache.php(1112): StubObject->__call(string, array)
#10 /srv/mediawiki/w/includes/cache/MessageCache.php(1112): StubObject->firstCallInit()
#11 /srv/mediawiki/w/includes/cache/MessageCache.php(1088): MessageCache->getParser()
#12 /srv/mediawiki/w/includes/Message.php(1241): MessageCache->transform(string, boolean, Language, NULL)
#13 /srv/mediawiki/w/includes/Message.php(874): Message->transformText(string)
#14 /srv/mediawiki/w/includes/Message.php(934): Message->toString(string)
#15 /srv/mediawiki/w/includes/user/User.php(900): Message->text()
#16 /srv/mediawiki/w/includes/user/User.php(1111): User::isUsableName(string)
#17 /srv/mediawiki/w/includes/auth/TemporaryPasswordPrimaryAuthenticationProvider.php(173): User::getCanonicalName(string, string)
#18 /srv/mediawiki/w/includes/auth/AuthManager.php(789): MediaWiki\Auth\TemporaryPasswordPrimaryAuthenticationProvider->testUserCanAuthenticate(string)
#19 /srv/mediawiki/w/includes/user/User.php(714): MediaWiki\Auth\AuthManager->userCanAuthenticate(string)
#20 /srv/mediawiki/w/extensions/Flow/includes/TalkpageManager.php(250): User::newSystemUser(string, array)
#21 /srv/mediawiki/w/extensions/Flow/includes/Conversion/Utils.php(448): Flow\TalkpageManager->getTalkpageManager()
#22 /srv/mediawiki/w/extensions/Flow/includes/Conversion/Utils.php(304): Flow\Conversion\Utils::generateForwardedCookieForCli()
#23 /srv/mediawiki/w/extensions/Flow/includes/Conversion/Utils.php(243): Flow\Conversion\Utils::getVRSObject()
#24 /srv/mediawiki/w/extensions/Flow/includes/Conversion/Utils.php(219): Flow\Conversion\Utils::getServiceClient()
#25 /srv/mediawiki/w/extensions/Flow/Hooks.php(168): Flow\Conversion\Utils::isParsoidConfigured()
#26 [internal function]: FlowHooks::initFlowExtension()
#27 /srv/mediawiki/w/includes/Setup.php(827): call_user_func(string)
#28 /srv/mediawiki/w/maintenance/doMaintenance.php(98): require_once(string)
#29 /srv/mediawiki/w/maintenance/rebuildLocalisationCache.php(181): require_once(string)
#30 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2017, 2:40 PM
Aklapper removed a subscriber: ContributionScores.

I tried rebuilding the localisation cache

Steps to reproduce (=commands) are welcome in bug reports.

Reception123 updated the task description. (Show Details)Aug 22 2017, 2:46 PM

Flow disabled, same result.

This one is marked as resolved in our tracker at Miraheze, @Reception123. Is it ok to close this bug, or did someone find the cause?

Aklapper closed this task as Declined.Oct 4 2017, 9:10 PM

This one is marked as resolved in our tracker at Miraheze, @Reception123. Is it ok to close this bug, or did someone find the cause?

Unfortunately closing this report as no further information has been provided.
@Reception123: After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!