Page MenuHomePhabricator

WikiEditor dropdowns open behind edit box on Mac Chrome
Closed, ResolvedPublic

Description

In WikiEditor, when I click a dropdown such as "Advanced / Heading" in the edit bar, sometimes the dropdown menu does not appear. It looks like the dropdown menu is rendering behind the edit box, i.e., the Z-index of the menu is incorrect. This is on a Macintosh (macOS Sierra 10.12.1) using Google Chrome (56.0.2924.87 64-bit). The problem does not occur in Chrome on our Microsoft Windows computers.

The problem is intermittent but occurs frequently. It may be a JavaScript race condition (order of operations) because the bug disappears when we turn on debugging.

We have reproduced this issue on two different Macs. It occurs on English Wikipedia today (MediaWiki 1.30.0-wmf.17 (259e37a) 21:23, 7 September 2017) and on our own MediaWiki 1.28.0 server.

I am attaching screenshots of the Heading dropdown when closed (closed.png), when open normally (open-normal.png), and when open as the bug occurs (open-with-bug.png). Notice in the third screenshot (with the red box), the first few pixel-rows of the menu appear -- you can tell because the area immediately below "Heading" is white rather than blue.

Details

Related Gerrit Patches:
mediawiki/extensions/WikiEditor : masterAnimations: Get rid of jquery animations

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 8 2017, 5:01 PM
maiden_taiwan updated the task description. (Show Details)Sep 8 2017, 5:02 PM
maiden_taiwan updated the task description. (Show Details)

Change 474821 had a related patch set uploaded (by TheDJ; owner: TheDJ):
[mediawiki/extensions/WikiEditor@master] Animations: Get rid of jquery animations

https://gerrit.wikimedia.org/r/474821

Change 474821 merged by jenkins-bot:
[mediawiki/extensions/WikiEditor@master] Animations: Get rid of jquery animations

https://gerrit.wikimedia.org/r/474821

Catrope closed this task as Resolved.Dec 3 2018, 8:47 PM
Catrope claimed this task.
happy5214 moved this task from Backlog to Closed on the WikiEditor board.Aug 4 2019, 11:34 AM