Page MenuHomePhabricator

WDQS returns incorrect data compared to what is in Wikidata
Closed, ResolvedPublic

Description

The WDQS is returning results that differ from what is in Wikidata. See T112397 for previous discussions.
Example:
Run the following SPARQL query:

select * where {
  wd:Q21990261 p:P361 ?s .
  ?s ps:P361 wd:Q24772701 .
  ?s prov:wasDerivedFrom ?ref .
  ?ref ?b ?c .
}

I get one row as a result:

srefbc
wds:Q21990261-99529C15-67CB-4166-860D-C4F68336183Ewdref:d472129d472e46ce41323852d3594fefc26467fapr:P854http://www.ebi.ac.uk/interpro/protein/A1Y9I9

If you look on Wikidata: https://www.wikidata.org/wiki/Q21990261#P361, this is missing the stated in on the reference.

If you run the same query with replacing the wd:Q21990261 with wd:Q21135100, you'll see the query works just fine.

Event Timeline

Gstupp created this task.Jun 4 2018, 6:56 PM
Restricted Application added a project: Discovery. · View Herald TranscriptJun 4 2018, 6:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Gstupp updated the task description. (Show Details)Jun 4 2018, 7:01 PM
Aklapper renamed this task from WDQS returns incorrect data to WDQS returns incorrect data compared to what is in Wikidata.Jun 4 2018, 8:22 PM
Smalyshev closed this task as Resolved.Jun 4 2018, 11:39 PM
Smalyshev claimed this task.
Smalyshev added a subscriber: Smalyshev.

Fixed, the root cause is the same as T194325, still working on that.

Vvjjkkii renamed this task from WDQS returns incorrect data compared to what is in Wikidata to snbaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Smalyshev as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from snbaaaaaaa to WDQS returns incorrect data compared to what is in Wikidata.Jul 1 2018, 10:01 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Smalyshev.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.