Page MenuHomePhabricator

RefToolbar no longer working on trwiki and orwiki
Closed, InvalidPublic

Description

The RefToolbar gadget, used to work fine until recently, stopped working on trwiki. The console output reads (when called using &debug=true)

//jQuery.Deferred exception: mwCustomEditButtons is not defined refbuttons@https://tr.wikipedia.org/w/index.php?title=MediaWiki:Kaynakyardimcisi.js/2.0a.js&action=raw&ctype=text/javascript:4:1//

Does it help at all to understand the issue?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 11 2018, 12:31 PM
Superyetkin triaged this task as High priority.Jul 11 2018, 12:32 PM
Superyetkin renamed this task from RefToolbar no longer working on trwili to RefToolbar no longer working on trwiki.

Unrelated to Gadgets-2.0 (please see its description) and to the WikiEditor codebase itself, hence removing these tags.

Aklapper closed this task as Invalid.Jul 11 2018, 1:34 PM

This function had shown a deprecation warning for years.

See https://www.mediawiki.org/wiki/ResourceLoader/Migration_guide_(users) how to migrate.

Closing as invalid as we usually do not track fixing on-wiki content in Phabricator tasks.

Nemo_bis reopened this task as Open.Jul 11 2018, 2:36 PM
Nemo_bis lowered the priority of this task from High to Normal.

I'm getting following error (google chrome, not using &debug=true)

Uncaught ReferenceError: mwCustomEditButtons is not defined
Aklapper closed this task as Invalid.Jul 11 2018, 2:54 PM

Why was this reopened? T199322#4415767 explains what needs to be updated on the wiki page.

Nemo_bis renamed this task from RefToolbar no longer working on trwiki to RefToolbar no longer working on trwiki and orwiki.Jul 15 2018, 8:28 AM
Nemo_bis reopened this task as Open.
Aklapper changed the task status from Open to Stalled.Jul 15 2018, 2:04 PM
Aklapper added a subscriber: Nemo_bis.

@Nemo_bis: Please either explain why you keep reopening a task which is about changing on-wiki content or refrain from editing this task. Thank you!

Superyetkin changed the task status from Stalled to Open.Jul 15 2018, 2:46 PM

The related gadget page has been updated, with no visible effect on functionality. Regarding the fact that the issue is not linited to a number of small wikis, it may need to be dealt with under a Phabricator ticket, possibly attracting developers familiar with the script.

Aklapper closed this task as Invalid.Jul 16 2018, 9:34 AM

Phabricator is not a general whiteboard to post problems with on-wiki content to hope that a developer might somehow get aware of this very ticket, sorry... by default we do not track gadget issues except for when maintainers/developers have requested this for a specific wiki or specific gadget.

(And I don't know what was "updated" either and how that is related. I only see 38kB of text added to that gadget page...)