Page MenuHomePhabricator

OpenGraphMeta's setmainimage tag not generating og:image
Closed, ResolvedPublic

Description

Steps to reproduce:

  • Add {{#setmainimage:Filename.ext}} to a page and save it.
  • Open the page in source mode to browser it's HTML

Actual result:

  • no og:image tag in the HTML.

Expected result:

  • og:image tag should be present in the HTML with the set image.

The reason the file namespace it not included in the parser function call is because the parser calls returns the name of the file, which then allows the call to be chained into a file call such: [[File:{{#setmainimage:Filename.ext}}|thumb|right|...]].

Event Timeline

Tinss created this task.Jul 18 2018, 5:16 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 18 2018, 5:16 AM
Tinss renamed this task from OpenGraphMeta's setmainimage tag not working to OpenGraphMeta's setmainimage tag not generating og:image.Jul 18 2018, 5:16 AM
Tinss removed Tinss as the assignee of this task.EditedAug 3 2018, 9:42 PM
Tinss added a project: Patch-For-Review.

Patch has been submitted in gerrit.

Tinss claimed this task.Aug 3 2018, 9:48 PM
Tinss closed this task as Resolved.Sep 29 2019, 12:06 PM

Bug was fixed in change ID: I64fb215117e7139bf3676902c66e08e9810243f1.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptSep 29 2019, 12:06 PM