Page MenuHomePhabricator

Does MW1.31 change it's way to load Localsettings.php?
Closed, DuplicatePublic

Description

Hi MW developers,

I am running a wiki farm with multiple wikis. The farm was archived by putting MW source code under /mediawiki folder. Then all other wikis have their own LocalSettings.php under their own folder, with linux soft link to point files/folders (index.php,includes,extensions, etc...) back to /mediawiki folder.

/www/mediawiki (all MW code, no config file, no web access)

/www/a (LocalSettings.php, soft link of files/folders to /mediawiki )
/www/b
/www/c
/www/d
...

Such settings work well since MW 1.25. However, after I upgrade the test wikis from 1.30 to 1.31. None of these wiki's LocalSettings.php took effect.

They all show "LocalSettings.php not found." if no setting file exist under /mediawiki folder. If I add a functional LocalSettings.php to /mediawiki folder, then all the other wikis now showing one same wiki.

What's changed in MW 1.31? What can I do to get MW to load different config file from different folder correctly?

Best wishes,
zog lun

Event Timeline

Zoglun created this task.Aug 7 2018, 5:19 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 7 2018, 5:19 AM
Zoglun updated the task description. (Show Details)Aug 7 2018, 5:22 AM
Zoglun updated the task description. (Show Details)
Aklapper closed this task as Invalid.

Hi, please do not ask the same question in several places and file general support requests in the MediaWiki support desk: https://www.mediawiki.org/wiki/Topic:Ui7oja763g4sey6q
Thank you.

Not a MW-1.31-release blocker - please see the project description.