Page MenuHomePhabricator

Scripts fail to load within Firefox for all WIkimedia sites
Closed, InvalidPublic

Description

Whenever I visit a Wikimedia site logged in or logged out, scripts fail to load, and the console of my browser (Firefox, last stable version: 62.0.3 (64-bit)) displays the following error:

Loading failed for the <script> with source “https://fr.wiktionary.org/w/load.php?debug=false&lang=fr&modules=Spinner%2Cjquery%2Coojs%2Csite%7Cext.3d%2CeventLogging%2CnavigationTiming%2CwikimediaEvents%7Cext.centralNotice.choiceData%2Cdisplay%2CgeoIP%2CimpressionDiet%2CkvStore%2CkvStoreMaintenance%2CstartUp%7Cext.centralauth.ForeignApi%7Cext.centralauth.centralautologin.clearcookie%7Cext.echo.api%2Cinit%7Cext.eventLogging.subscriber%7Cext.uls.common%2Ceventlogger%2Cinit%2Cinterface%2Cpreferences%2Cwebfonts%7Cext.visualEditor.desktopArticleTarget.init%7Cext.visualEditor.supportCheck%2CtargetLoader%2CtempWikitextEditorWidget%2Ctrack%2Cve%7Cext.wikimediaEvents.loggedin%7Cjquery.accessKeyLabel%2CcheckboxShiftClick%2Cclient%2Ccookie%2CembedPlayer%2CgetAttrs%2ChighlightText%2CloadingSpinner%2CmwEmbedUtil%2Cspinner%2Csuggestions%2CtabIndex%2CtextSelection%2Cthrottle-debounce%2CtriggerQueueCallback%7Cjquery.uls.data%7Cmediawiki.ForeignApi%2CRegExp%2CString%2CTitle%2CUri%2Capi%2Cbase%2Ccldr%2Ccookie%2Cexperiments%2CjqueryMsg%2Clanguage%2Cnotification%2Cnotify%2CsearchSuggest%2Cstorage%2Ctemplate%2Ctoc%2Ctoolbar%2Cuser%2Cutil%2CvisibleTimeout%7Cmediawiki.ForeignApi.core%7Cmediawiki.editfont.styles%7Cmediawiki.legacy.wikibits%7Cmediawiki.libs.pluralruleparser%7Cmediawiki.page.ready%2Cstartup%7Cmediawiki.page.watch.ajax%7Cmediawiki.template.regexp%7Cmediawiki.ui.button%2Cicon%7Cmmv.bootstrap%2Chead%7Cmmv.bootstrap.autostart%7Cmw.EmbedPlayer.loader%7Cmw.MediaWikiPlayer.loader%7Cmw.MwEmbedSupport%2CPopUpMediaTransform%7Cmw.MwEmbedSupport.style%7Cmw.PopUpMediaTransform.styles%7Cmw.TMHGalleryHook.js%7Cmw.TimedText.loader%7Cschema.UniversalLanguageSelector%7Cskins.vector.js%7Cuser.defaults&skin=vector&version=09t0hjk”.

This occurs on any Wikimedia site (tested on en.wp, en.wikt, fr.wikt).

Note: this does not occur within Google Chrome.

Because of that, all gadgets are disabled.

Event Timeline

Automatik created this task.Oct 5 2018, 2:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 5 2018, 2:33 PM
Automatik triaged this task as High priority.Oct 5 2018, 2:35 PM

Do you have an adblocker or similar installed in Firefox, by any chance? The fact that this does not occur in Chrome makes it almost certain that this is browser configuration related.

To test:

  • In Firefox, click on the "Help" menu
  • Select "Restart with Add-Ons disabled"
  • Try opening fr.wiktionary.org, and see if the same message appears.
Aklapper raised the priority of this task from High to Needs Triage.EditedOct 5 2018, 2:43 PM

@Automatik: Resetting priority as long as nobody else has seen this. See https://www.mediawiki.org/wiki/Phabricator/Project_management#Setting_task_priorities
Please do not set the priority field if you don't plan to work on this. Thanks!

Aklapper changed the task status from Open to Stalled.Oct 5 2018, 2:44 PM
Automatik added a comment.EditedOct 5 2018, 2:59 PM

Do you have an adblocker or similar installed in Firefox, by any chance? The fact that this does not occur in Chrome makes it almost certain that this is browser configuration related.

To test:

  • In Firefox, click on the "Help" menu
  • Select "Restart with Add-Ons disabled"
  • Try opening fr.wiktionary.org, and see if the same message appears.

Thanks for your helpful answer: I restarted Firefox without add-ons and then again with add-ons, and it's working fine again! :)

Automatik closed this task as Resolved.Oct 5 2018, 2:59 PM
Aklapper changed the task status from Resolved to Invalid.Oct 5 2018, 10:35 PM

(Changing task status to invalid as no Wikimedia code was changed and as the problem was on the reporter's computer.)