Page MenuHomePhabricator

Git push and pull don't complete
Closed, ResolvedPublic

Description

Since a few days I can't push to or pull from git on stat1005.
Both 'git pull' and 'git push' hang. Could you please take a look?

Event Timeline

ezachte created this task.Oct 5 2018, 2:49 PM
Restricted Application added a project: Analytics. · View Herald TranscriptOct 5 2018, 2:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
elukey added a subscriber: elukey.Oct 5 2018, 2:59 PM

Hi Erik, can you give me an example of command that you give that hangs? git should use by default http_proxy configs on stat1005 (system property), but it might not work with your settings.

elukey added a comment.Oct 5 2018, 3:00 PM
Last login: Wed Oct  3 10:23:32 2018 from 91.198.174.113
elukey@stat1005:~$ cat /etc/gitconfig
# vim: set ts=4 sw=4 et:
# This file is managed by Puppet!
# puppet:://modules/git/gitconfig.erb
# git::userconfig for 'git::systemconfig'

[http]
proxy = http://webproxy.eqiad.wmnet:8080
[https]
proxy = http://webproxy.eqiad.wmnet:8080

HTTP is blocked by the Analytics firewall rules, except if done via webproxy.

elukey claimed this task.Oct 8 2018, 3:36 PM
elukey triaged this task as Low priority.
elukey added a project: User-Elukey.
elukey added a subscriber: Ottomata.
mforns moved this task from Incoming to Radar on the Analytics board.Oct 8 2018, 3:46 PM
ezachte raised the priority of this task from Low to Normal.Oct 15 2018, 10:43 AM

Updating priority as I need to check-in bug fixes, which is way overdue. thanks.

Updating priority as I need to check-in bug fixes, which is way overdue. thanks.

Erik did you see my questions above? It is fine to keep the task as "normal" but there are missing info in this task. Can you please follow up on what I asked above? I'd need a way to reproduce before finding what's wrong :)

Luca, the commands I use are in my first comment. So Both 'git pull' and 'git push' hang.
To be sure I checked my aliasses: nope these are the original commands.

So I may be not understand your question then.
Could you please rephrase it? Thanks

I'd need to know the following data:

  1. path of the git repository that doesn't work (or more than one if it doesn't in multiple places).
  2. user that runs the git pull/push (I guess yours but worth to check)

Then I'll try to execute those commands and see if I can reproduce. As written above, you should already be using the proxy commands, http doesn't work otherwise due to the firewall, maybe there's something in your settings that makes it not working (speculating, still have no idea :)

Yes, it's me who issues the command.

You should already be using the proxy commands

I don't know really. I'm more or less blank on anything configuration-wise, especially related to git :-(

git repository is in /home/ezachte/wikistats/

if you have further questions, I'll be back in a few hours. Thanks

elukey added a subscriber: ayounsi.Oct 15 2018, 2:04 PM

Thanks Erik, it should work now :)

If you type the following you can check if your git repo is using a proxy:

ezachte@stat1005:/home/ezachte/wikistats$ git config http.proxy
http://webproxy.eqiad.wmnet:8080
ezachte@stat1005:/home/ezachte/wikistats$ git config https.proxy
http://webproxy.eqiad.wmnet:8080

As you can see the system config is correctly picked up. This was the problem:

ezachte@stat1005:/home/ezachte/wikistats$ cat .git/config
[..]
[remote "origin"]
	fetch = +refs/heads/*:refs/remotes/origin/*
	url = ssh://ezachte@gerrit.wikimedia.org:29418/analytics/wikistats.git
[..]

So git is configured to use ssh not https. The firewall was allowing only cobalt's IP for port 29418, not the gerrit.wikimedia.org's IP. I changed it in the firewall and now everything works fine.

@ayounsi Let me know if this is not ok to you. I swapped cobalt's ipv4/6 in the analytics-in4/6 filters, it seems not correct to me.

Mentioned in SAL (#wikimedia-analytics) [2018-10-15T14:05:00Z] <elukey> swapped cobalt's ip with gerrit.wikimedia.org's one in analytics-in(4|6) firewall filters on the eqiad routers for https://phabricator.wikimedia.org/T206331#4666622. This should not cause git pulls to fail but let me know in case it does.

ezachte closed this task as Resolved.Oct 16 2018, 1:09 PM

@elukey yes, it works like a charm now, thanks so much :-)

@ayounsi Let me know if this is not ok to you. I swapped cobalt's ipv4/6 in the analytics-in4/6 filters, it seems not correct to me.

Looks good to me!