Page MenuHomePhabricator

Proposal: QA: Automation Testing - port Echo Notification tests to Node.js
Closed, ResolvedPublic

Description

Profile Information
Name: Giselle J
Email: thinkcolorful@thinkcolorful.org
Web page: https://thinkcolorful.org
Location: Pittsburgh, PA, US
Working hours: 12pm to 8pm EST (4pm to 12am UTC) and one day on the weekends 9am-5pm EST (1pm-9pm UTC, Sat or Sundays that alternate week to week)

Synopsis
Mediawiki is software that is collaboratively worked on and expanded by a diverse set of developers. The purpose of this project is to create automated tests to check that updates to the changes made to the code base do no break existing components.
The task at hand is to port existing tests for the Echo extension from Ruby into JavaScript and expand on this test set depending on the needs as they arise during the four month period. Providing commented code will be important for future readability and debugging.
Mentors: @Etonkovidova

Deliverables
Deliverables will include:

  • Development of tests scripts written in Javascript.
  • Commenting code for added readability/clarity.
  • Submitting code to Git/Gerrit for code review and integration.

Participation

  • I will write weekly status reports on my blog and send this to my mentor via email.
  • If questions and issues arise, I will communicate with my mentor.
  • Attend any program-related meetings that are hosted

About Me
I am a single mom and have been out of the tech workforce for about decade. Though I’ve worked various jobs during that time, I did take the three years off to raise my child. I’m looking to expand my skill set and work on a project that allows me to write code. I’ve done a bit of this sort of work for fun and in my spare time but would like to grow it. When I first learned about free and open source software I was impressed with how transparent and community oriented the projects were compared to the alternatives. I learned to run a server at home to try out all the different, interesting sorts of software that is available, including mediawiki! This experience has provided me a lot of confidence in pursuing this skill trajectory and provided a good sandbox for experimentation and exploration. The last couple of years has been focusing on doing community outreach and organizing and free and open source software always seems to have a place within this sphere.

I do not have any commitments that would interfere with working a forty-hour week.
The only exception is December 24 - 26 (Christmas) and New Years Day, when I will be offline for the holidays.

Past Experience
I worked as a QA engineer at a tech/media company in 2008. I wrote test cases and did a variety of different types of manual testing (Static, Functional, Performance, Regression, Grey box, Section 508). I help setup the bug tracking system(Mantis) and documented and submitted bugs as they arose. I have a general understanding on how to write the tests and perform them so I’m excited to learn how to automate them.
I’m comfortable running and setting up wikis based on medawiki’s code base and am an active user. I have familiarity HTML, CSS, and JavaScript.

Any Other Info
Contributions to the testing project so far:
Environment Setup: https://thinkcolorful.org/?p=489
Echo Tests: https://thinkcolorful.org/?p=500
Welcome Test: https://thinkcolorful.org/?p=516

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 30 2018, 3:33 PM
Ephemeralwaves updated the task description. (Show Details)

@Ephemeralwaves Is there anything remaining in this task from Outreachy Round 17? If not, then please consider marking it as resolved!

Etonkovidova closed this task as Resolved.Aug 7 2019, 9:45 PM
Etonkovidova claimed this task.

Closing since the task has been done during Outreachy term. @Ephemeralwaves currently works on other Automation tests tasks.