Page MenuHomePhabricator

tools-sgewebgrid-lighttpd-0904 has bad state in OpenStack
Closed, ResolvedPublic

Description

Horizon thinks the instance tools-sgewebgrid-lighttpd-0904 is running on cloudvirt1026, but cloudvirt1026 does not show the instance in virsh list output. @Andrew cold-migrated this instance from the old region to eqiad1-r and found some bugs in the migration script along the way. We think the best thing to do at this point is delete the instance and rebuild it.

Event Timeline

bd808 created this task.Jan 23 2019, 8:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 23 2019, 8:32 PM

Mentioned in SAL (#wikimedia-cloud) [2019-01-23T20:53:46Z] <bd808> Deleted broken tools-sgewebgrid-lighttpd-0904 instance via Horizon (T214519)

bd808 added a comment.Jan 23 2019, 9:02 PM

Grid does not like a missing host :/

$ sudo /usr/local/bin/grid-configurator --all-domains --observer-pass $(grep OS_PASSWORD /etc/novaobserver.yaml|awk '{gsub(/"/,"",$2);print $2}')
Host object "tools-sgewebgrid-lighttpd-0904.tools.eqiad.wmflabs" is still referenced in cluster queue "webgrid-lighttpd".
Traceback (most recent call last):
  File "/usr/local/bin/grid-configurator", line 556, in <module>
    main()
  File "/usr/local/bin/grid-configurator", line 544, in main
    host_processor.run_updates(args.dry_run, GRID_HOST_TYPE)
  File "/usr/local/bin/grid-configurator", line 409, in run_updates
    check=True,
  File "/usr/lib/python3.5/subprocess.py", line 398, in run
    output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command '['qconf', '-de', 'tools-sgewebgrid-lighttpd-0904.tools.eqiad.wmflabs']' returned non-zero exit status 1

Mentioned in SAL (#wikimedia-cloud) [2019-01-23T21:04:17Z] <bd808> Building new tools-sgewebgrid-lighttpd-0904 instance (T214519)

bd808 added a comment.Jan 23 2019, 9:37 PM

Lots of apt failures in the puppet runs right now:

Warning: /Stage[main]/Profile::Locales::Extended/Exec[locale-gen]: Skipping because of failed dependencies
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-gdal' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libarmadillo4 libarpack2 libblas-common libblas3 libdap11
  libdapclient3 libdapserver7 libepsilon1 libfreexl1 libgcc1 libgdal1h
  libgeos-3.4.2 libgeos-c1 libgfortran3 libgomp1 libhdf4-0-alt libhdf5-8
  libkml0 liblapack3 libnetcdfc7 libogdi3.2 libquadmath0 libspatialite5
  libstdc++6 liburiparser1 libxerces-c3.1 odbcinst odbcinst1debian2
  python-numpy
Suggested packages:
  libhdf4-doc libhdf4-alt-dev hdf4-tools libnetcdf4 ogdi-bin gcc gfortran
  python-dev python-numpy-dbg python-numpy-doc
Recommended packages:
  proj-bin
The following NEW packages will be installed:
  libarmadillo4 libarpack2 libblas-common libblas3 libdap11 libdapclient3
  libdapserver7 libepsilon1 libfreexl1 libgdal1h libgeos-3.4.2 libgeos-c1
  libgfortran3 libhdf4-0-alt libhdf5-8 libkml0 liblapack3 libnetcdfc7
  libogdi3.2 libquadmath0 libspatialite5 liburiparser1 libxerces-c3.1 odbcinst
  odbcinst1debian2 python-gdal python-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 27 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 14.6 MB of archives.
After this operation, 54.3 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python_gdal/Package[python-gdal]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-gdal' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libarmadillo4 libarpack2 libblas-common libblas3 libdap11
  libdapclient3 libdapserver7 libepsilon1 libfreexl1 libgcc1 libgdal1h
  libgeos-3.4.2 libgeos-c1 libgfortran3 libgomp1 libhdf4-0-alt libhdf5-8
  libkml0 liblapack3 libnetcdfc7 libogdi3.2 libquadmath0 libspatialite5
  libstdc++6 liburiparser1 libxerces-c3.1 odbcinst odbcinst1debian2
  python-numpy
Suggested packages:
  libhdf4-doc libhdf4-alt-dev hdf4-tools libnetcdf4 ogdi-bin gcc gfortran
  python-dev python-numpy-dbg python-numpy-doc
Recommended packages:
  proj-bin
The following NEW packages will be installed:
  libarmadillo4 libarpack2 libblas-common libblas3 libdap11 libdapclient3
  libdapserver7 libepsilon1 libfreexl1 libgdal1h libgeos-3.4.2 libgeos-c1
  libgfortran3 libhdf4-0-alt libhdf5-8 libkml0 liblapack3 libnetcdfc7
  libogdi3.2 libquadmath0 libspatialite5 liburiparser1 libxerces-c3.1 odbcinst
  odbcinst1debian2 python-gdal python-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 27 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 14.6 MB of archives.
After this operation, 54.3 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-gdal' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libarmadillo4 libarpack2 libblas-common libblas3 libdap11
  libdapclient3 libdapserver7 libepsilon1 libfreexl1 libgcc1 libgdal1h
  libgeos-3.4.2 libgeos-c1 libgfortran3 libgomp1 libhdf4-0-alt libhdf5-8
  libkml0 liblapack3 libnetcdfc7 libogdi3.2 libquadmath0 libspatialite5
  libstdc++6 liburiparser1 libxerces-c3.1 odbcinst odbcinst1debian2
  python3-numpy
Suggested packages:
  libhdf4-doc libhdf4-alt-dev hdf4-tools libnetcdf4 ogdi-bin gcc gfortran
  python-numpy-doc python3-dev python3-numpy-dbg
Recommended packages:
  proj-bin
The following NEW packages will be installed:
  libarmadillo4 libarpack2 libblas-common libblas3 libdap11 libdapclient3
  libdapserver7 libepsilon1 libfreexl1 libgdal1h libgeos-3.4.2 libgeos-c1
  libgfortran3 libhdf4-0-alt libhdf5-8 libkml0 liblapack3 libnetcdfc7
  libogdi3.2 libquadmath0 libspatialite5 liburiparser1 libxerces-c3.1 odbcinst
  odbcinst1debian2 python3-gdal python3-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 27 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 14.4 MB of archives.
After this operation, 53.9 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python3_gdal/Package[python3-gdal]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-gdal' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libarmadillo4 libarpack2 libblas-common libblas3 libdap11
  libdapclient3 libdapserver7 libepsilon1 libfreexl1 libgcc1 libgdal1h
  libgeos-3.4.2 libgeos-c1 libgfortran3 libgomp1 libhdf4-0-alt libhdf5-8
  libkml0 liblapack3 libnetcdfc7 libogdi3.2 libquadmath0 libspatialite5
  libstdc++6 liburiparser1 libxerces-c3.1 odbcinst odbcinst1debian2
  python3-numpy
Suggested packages:
  libhdf4-doc libhdf4-alt-dev hdf4-tools libnetcdf4 ogdi-bin gcc gfortran
  python-numpy-doc python3-dev python3-numpy-dbg
Recommended packages:
  proj-bin
The following NEW packages will be installed:
  libarmadillo4 libarpack2 libblas-common libblas3 libdap11 libdapclient3
  libdapserver7 libepsilon1 libfreexl1 libgdal1h libgeos-3.4.2 libgeos-c1
  libgfortran3 libhdf4-0-alt libhdf5-8 libkml0 liblapack3 libnetcdfc7
  libogdi3.2 libquadmath0 libspatialite5 liburiparser1 libxerces-c3.1 odbcinst
  odbcinst1debian2 python3-gdal python3-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 27 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 14.4 MB of archives.
After this operation, 53.9 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-matplotlib' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  libjs-jquery-ui liblapack3 libquadmath0 libstdc++6 python-matplotlib-data
  python-mock python-numpy
Suggested packages:
  libjs-jquery-ui-docs gir1.2-gtk-3.0 ipython python-cairocffi
  python-excelerator python-gobject python-gtk2 python-matplotlib-doc
  python-qt4 python-scipy python-tornado python-traits python-wxgtk3.0
  ttf-staypuft python-mock-doc gcc gfortran python-dev python-numpy-dbg
  python-numpy-doc
Recommended packages:
  javascript-common python-glade2
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 libjs-jquery-ui liblapack3 libquadmath0
  python-matplotlib python-matplotlib-data python-mock python-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 10 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 11.9 MB of archives.
After this operation, 38.1 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python_matplotlib/Package[python-matplotlib]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-matplotlib' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  libjs-jquery-ui liblapack3 libquadmath0 libstdc++6 python-matplotlib-data
  python-mock python-numpy
Suggested packages:
  libjs-jquery-ui-docs gir1.2-gtk-3.0 ipython python-cairocffi
  python-excelerator python-gobject python-gtk2 python-matplotlib-doc
  python-qt4 python-scipy python-tornado python-traits python-wxgtk3.0
  ttf-staypuft python-mock-doc gcc gfortran python-dev python-numpy-dbg
  python-numpy-doc
Recommended packages:
  javascript-common python-glade2
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 libjs-jquery-ui liblapack3 libquadmath0
  python-matplotlib python-matplotlib-data python-mock python-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 10 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 11.9 MB of archives.
After this operation, 38.1 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-matplotlib' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  libjs-jquery-ui liblapack3 libquadmath0 libstdc++6 python-matplotlib-data
  python3-numpy
Suggested packages:
  libjs-jquery-ui-docs gir1.2-gtk-3.0 ipython3 python-matplotlib-doc
  python3-cairocffi python3-gi-cairo python3-pyqt4 python3-scipy python3-sip
  python3-tornado ttf-staypuft gcc gfortran python-numpy-doc python3-dev
  python3-numpy-dbg
Recommended packages:
  javascript-common
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 libjs-jquery-ui liblapack3 libquadmath0
  python-matplotlib-data python3-matplotlib python3-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 9 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 11.8 MB of archives.
After this operation, 37.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python3_matplotlib/Package[python3-matplotlib]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-matplotlib' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  libjs-jquery-ui liblapack3 libquadmath0 libstdc++6 python-matplotlib-data
  python3-numpy
Suggested packages:
  libjs-jquery-ui-docs gir1.2-gtk-3.0 ipython3 python-matplotlib-doc
  python3-cairocffi python3-gi-cairo python3-pyqt4 python3-scipy python3-sip
  python3-tornado ttf-staypuft gcc gfortran python-numpy-doc python3-dev
  python3-numpy-dbg
Recommended packages:
  javascript-common
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 libjs-jquery-ui liblapack3 libquadmath0
  python-matplotlib-data python3-matplotlib python3-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 9 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 11.8 MB of archives.
After this operation, 37.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-numpy' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6
Suggested packages:
  gcc gfortran python-dev python-numpy-dbg python-numpy-doc
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0 python-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 6 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 4552 kB of archives.
After this operation, 16.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python_numpy/Package[python-numpy]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-numpy' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6
Suggested packages:
  gcc gfortran python-dev python-numpy-dbg python-numpy-doc
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0 python-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 6 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 4552 kB of archives.
After this operation, 16.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-numpy' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6
Suggested packages:
  gcc gfortran python-numpy-doc python3-dev python3-numpy-dbg
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0 python3-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 6 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 4549 kB of archives.
After this operation, 16.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python3_numpy/Package[python3-numpy]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-numpy' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6
Suggested packages:
  gcc gfortran python-numpy-doc python3-dev python3-numpy-dbg
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0 python3-numpy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 6 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 4549 kB of archives.
After this operation, 16.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-opencv' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  libgtkglext1 liblapack3 libopencv-calib3d2.4 libopencv-contrib2.4
  libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4
  libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4
  libopencv-ml2.4 libopencv-objdetect2.4 libopencv-photo2.4 libopencv-video2.4
  libpangox-1.0-0 libquadmath0 libstdc++6 python-numpy
Suggested packages:
  gcc gfortran python-dev python-numpy-dbg python-numpy-doc
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 libgtkglext1 liblapack3
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-photo2.4 libopencv-video2.4 libpangox-1.0-0
  libquadmath0 python-numpy python-opencv
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 21 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 8451 kB of archives.
After this operation, 29.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python_opencv/Package[python-opencv]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-opencv' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  libgtkglext1 liblapack3 libopencv-calib3d2.4 libopencv-contrib2.4
  libopencv-core2.4 libopencv-features2d2.4 libopencv-flann2.4
  libopencv-highgui2.4 libopencv-imgproc2.4 libopencv-legacy2.4
  libopencv-ml2.4 libopencv-objdetect2.4 libopencv-photo2.4 libopencv-video2.4
  libpangox-1.0-0 libquadmath0 libstdc++6 python-numpy
Suggested packages:
  gcc gfortran python-dev python-numpy-dbg python-numpy-doc
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 libgtkglext1 liblapack3
  libopencv-calib3d2.4 libopencv-contrib2.4 libopencv-core2.4
  libopencv-features2d2.4 libopencv-flann2.4 libopencv-highgui2.4
  libopencv-imgproc2.4 libopencv-legacy2.4 libopencv-ml2.4
  libopencv-objdetect2.4 libopencv-photo2.4 libopencv-video2.4 libpangox-1.0-0
  libquadmath0 python-numpy python-opencv
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 21 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 8451 kB of archives.
After this operation, 29.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-pandas' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6 python-numpy python-pandas-lib
Suggested packages:
  gcc gfortran python-dev python-numpy-dbg python-numpy-doc python-pandas-doc
Recommended packages:
  python-scipy python-matplotlib python-tables python-numexpr python-xlrd
  python-statsmodels python-openpyxl python-xlwt python-bs4 python-html5lib
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0 python-numpy
  python-pandas python-pandas-lib
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 8 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 7115 kB of archives.
After this operation, 30.9 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python_pandas/Package[python-pandas]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-pandas' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6 python-numpy python-pandas-lib
Suggested packages:
  gcc gfortran python-dev python-numpy-dbg python-numpy-doc python-pandas-doc
Recommended packages:
  python-scipy python-matplotlib python-tables python-numexpr python-xlrd
  python-statsmodels python-openpyxl python-xlwt python-bs4 python-html5lib
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0 python-numpy
  python-pandas python-pandas-lib
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 8 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 7115 kB of archives.
After this operation, 30.9 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-pandas' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6 python3-numpy python3-pandas-lib
Suggested packages:
  gcc gfortran python-numpy-doc python3-dev python3-numpy-dbg
  python-pandas-doc
Recommended packages:
  python3-scipy python3-matplotlib python3-numexpr python3-tables python3-bs4
  python3-html5lib
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0 python3-numpy
  python3-pandas python3-pandas-lib
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 8 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 7071 kB of archives.
After this operation, 30.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python3_pandas/Package[python3-pandas]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-pandas' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6 python3-numpy python3-pandas-lib
Suggested packages:
  gcc gfortran python-numpy-doc python3-dev python3-numpy-dbg
  python-pandas-doc
Recommended packages:
  python3-scipy python3-matplotlib python3-numexpr python3-tables python3-bs4
  python3-html5lib
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0 python3-numpy
  python3-pandas python3-pandas-lib
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 8 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 7071 kB of archives.
After this operation, 30.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-rsvg' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libpango1.0-0 libpangox-1.0-0 libpangoxft-1.0-0 libquadmath0
  libstdc++6 python-cairo python-gobject-2 python-gtk2 python-numpy
Suggested packages:
  python-gobject-2-dbg python-gtk2-doc gcc gfortran python-dev
  python-numpy-dbg python-numpy-doc
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libpango1.0-0
  libpangox-1.0-0 libpangoxft-1.0-0 libquadmath0 python-cairo python-gobject-2
  python-gtk2 python-numpy python-rsvg
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 13 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 6082 kB of archives.
After this operation, 22.0 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python_rsvg/Package[python-rsvg]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-rsvg' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libpango1.0-0 libpangox-1.0-0 libpangoxft-1.0-0 libquadmath0
  libstdc++6 python-cairo python-gobject-2 python-gtk2 python-numpy
Suggested packages:
  python-gobject-2-dbg python-gtk2-doc gcc gfortran python-dev
  python-numpy-dbg python-numpy-doc
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libpango1.0-0
  libpangox-1.0-0 libpangoxft-1.0-0 libquadmath0 python-cairo python-gobject-2
  python-gtk2 python-numpy python-rsvg
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 13 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 6082 kB of archives.
After this operation, 22.0 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-scipy' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6 python-decorator python-numpy
Suggested packages:
  gcc gfortran python-dev python-numpy-dbg python-numpy-doc
Recommended packages:
  g++ c++-compiler
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0
  python-decorator python-numpy python-scipy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 8 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 12.7 MB of archives.
After this operation, 49.1 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python_scipy/Package[python-scipy]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-scipy' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6 python-decorator python-numpy
Suggested packages:
  gcc gfortran python-dev python-numpy-dbg python-numpy-doc
Recommended packages:
  g++ c++-compiler
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0
  python-decorator python-numpy python-scipy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 8 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 12.7 MB of archives.
After this operation, 49.1 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-scipy' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6 python3-decorator python3-numpy
Suggested packages:
  gcc gfortran python-numpy-doc python3-dev python3-numpy-dbg
Recommended packages:
  g++ c++-compiler
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0
  python3-decorator python3-numpy python3-scipy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 8 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 12.3 MB of archives.
After this operation, 44.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Packages::Python3_scipy/Package[python3-scipy]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python3-scipy' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libblas-common libblas3 libgcc1 libgfortran3 libgomp1
  liblapack3 libquadmath0 libstdc++6 python3-decorator python3-numpy
Suggested packages:
  gcc gfortran python-numpy-doc python3-dev python3-numpy-dbg
Recommended packages:
  g++ c++-compiler
The following NEW packages will be installed:
  libblas-common libblas3 libgfortran3 liblapack3 libquadmath0
  python3-decorator python3-numpy python3-scipy
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 8 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 12.3 MB of archives.
After this operation, 44.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install libvips38' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libcfitsio2 libgcc1 libgfortran3 libgomp1 libgsf-1-114
  libgsf-1-common libhdf5-8 libmatio2 libopenslide0 libquadmath0 libstdc++6
Recommended packages:
  nip2
The following NEW packages will be installed:
  libcfitsio2 libgfortran3 libgsf-1-114 libgsf-1-common libhdf5-8 libmatio2
  libopenslide0 libquadmath0 libvips38
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 9 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 3619 kB of archives.
After this operation, 10.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Error: /Stage[main]/Profile::Toolforge::Grid::Exec_environ/Package[libvips38]/ensure: change from purged to latest failed: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install libvips38' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  apt-file libconfig-file-perl libmono-c5-1.1-cil libmono-corlib2.0-cil
  libmono-entityframework-sqlserver6.0-cil libmono-entityframework6.0-cil
  libmono-opensystem-c4.0-cil libmono-sharpzip2.6-cil libmono-system2.0-cil
  libmono-web4.0-cil libmonoboehm-2.0-dev libopts25 libregexp-assemble-perl
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gcc-4.9-base libcfitsio2 libgcc1 libgfortran3 libgomp1 libgsf-1-114
  libgsf-1-common libhdf5-8 libmatio2 libopenslide0 libquadmath0 libstdc++6
Recommended packages:
  nip2
The following NEW packages will be installed:
  libcfitsio2 libgfortran3 libgsf-1-114 libgsf-1-common libhdf5-8 libmatio2
  libopenslide0 libquadmath0 libvips38
The following packages will be DOWNGRADED:
  gcc-4.9-base libgcc1 libgomp1 libstdc++6
0 upgraded, 9 newly installed, 4 downgraded, 0 to remove and 22 not upgraded.
Need to get 3619 kB of archives.
After this operation, 10.7 MB of additional disk space will be used.
E: There are problems and -y was used without --force-yes
Notice: Applied catalog in 58.91 seconds

Turns out I built a Jessie instance instead of a stretch instance. :/ Time to try again.

Mentioned in SAL (#wikimedia-cloud) [2019-01-23T22:09:43Z] <bd808> Deleted tools-sgewebgrid-lighttpd-0904 instance via Horizon, used wrong base image (T214519)

Mentioned in SAL (#wikimedia-cloud) [2019-01-23T22:18:24Z] <bd808> Building new tools-sgewebgrid-lighttpd-0904 instance using Stretch base image (T214519)

The puppet runs look much better when your base OS is the expected version. :)

bd808 closed this task as Resolved.Jan 23 2019, 11:08 PM
bd808 claimed this task.