Page MenuHomePhabricator

update.php broken on beta: Fatal error: Uncaught exception 'ConfigException' Failed to load configuration from etcd: cURL error 23: Failed writing header
Closed, ResolvedPublic

Description

The beta-update-databases-eqiad Jenkins job updates the Beta-Cluster-Infrastructure MediaWiki database on an hourly basis.

On March 5th 2019 at 20:20 UTC it started failing:

Message
echo 'aawiki'; /usr/local/bin/mwscript update.php --wiki=aawiki --quick
aawiki
#!/usr/bin/env php
Warning: Invalid argument: option: 6 in /srv/mediawiki-staging/php-master/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 56
Warning: Invalid argument: option: 6 in /srv/mediawiki-staging/php-master/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 56
Warning: Invalid argument: function: not string, closure, or array in /srv/mediawiki-staging/php-master/vendor/guzzlehttp/guzzle/src/Handler/CurlMultiHandler.php on line 108
...

Fatal error: Uncaught exception 'ConfigException'
with message 'Failed to load configuration from etcd: cURL error 23: Failed writing header (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)
in /srv/mediawiki-staging/php-master/includes/config/EtcdConfig.php:200
trace
Stack trace:
#0 /srv/mediawiki-staging/php-master/includes/config/EtcdConfig.php(123): EtcdConfig->load()
#1 /srv/mediawiki-staging/wmf-config/etcd.php(43): EtcdConfig->getModifiedIndex()
#2 /srv/mediawiki-staging/wmf-config/etcd.php(49): wmfSetupEtcd()
#3 /srv/mediawiki-staging/wmf-config/CommonSettings.php(134): wmfEtcdConfig()
#4 /srv/mediawiki-staging/php-master/LocalSettings.php(5): include()
#5 /srv/mediawiki-staging/php-master/includes/Setup.php(105): include()
#6 /srv/mediawiki-staging/php-master/maintenance/doMaintenance.php(81): include()
#7 /srv/mediawiki-staging/php-master/maintenance/update.php(248): include()
#8 /srv/mediawiki-staging/multiversion/MWScript.php(100): include()
#9 {main}

To reproduce:

ssh deployment-deploy01.deployment-prep.eqiad.wmflabs
echo 1|mwscript eval.php --wiki=enwiki

Event Timeline

hashar created this task.Mar 6 2019, 8:21 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 6 2019, 8:21 AM
hashar updated the task description. (Show Details)Mar 6 2019, 8:36 AM
hashar added a subscriber: Joe.Mar 6 2019, 8:45 AM

@Joe are you aware of any changes related to Etcd on beta yesterday evening? It magic started to break but I can't find any related change in mediawiki-config / mediawiki/core :(

hashar added a comment.Mar 6 2019, 8:52 AM

Sorry @Joe eventually I found out it is due to an issue in mediawiki/core

Convert MultiHttpClient to use Guzzle
1e048a08b565ae909e85465f8b09a27ed8480ce2
https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/454346/

hashar removed a subscriber: Joe.Mar 6 2019, 8:52 AM

Change 494663 had a related patch set uploaded (by Hashar; owner: Hashar):
[mediawiki/core@master] Revert "Convert MultiHttpClient to use Guzzle"

https://gerrit.wikimedia.org/r/494663

hashar added a comment.Mar 6 2019, 8:56 AM

Will be solved as soon as the revert https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/494663/ is merged and deployed on beta.

Change 494663 merged by jenkins-bot:
[mediawiki/core@master] Revert "Convert MultiHttpClient to use Guzzle"

https://gerrit.wikimedia.org/r/494663

hashar closed this task as Resolved.Mar 6 2019, 9:27 AM
hashar claimed this task.

The job ran just fine!