Page MenuHomePhabricator

Long prefixes and short prefixes link to different language projects in non-english projects
Closed, DeclinedPublic

Description

Long prefixes and short prefixes link to same language projects in english projects, for example in enwiki:

[[wikisource:example]] and [[s:example]] link to english wikisource

But in non-english projects, Long prefixes and short prefixes link to different language projects, for example in zhwiki:
[[wikisource:example]] link to english wikisource, [[s:example]] link to chinese wikisource. And see test case in zhwiki: https://zh.wikipedia.org/wiki/User:Shizhao/T218757

For non-English projects, there is a lot of confusion in the use.

Event Timeline

Shizhao created this task.Mar 20 2019, 6:55 AM
Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptMar 20 2019, 6:55 AM
Shizhao updated the task description. (Show Details)Mar 20 2019, 7:00 AM

This problem seems to be caused by the conflict between Special:SiteMatrix and Interwiki map?

Liuxinyu970226 added a subscriber: Liuxinyu970226.

@Shizhao Problems that are about SiteMatrix are categorized in their own project,

94rain added a subscriber: 94rain.Mar 22 2019, 2:08 AM

please also fix other prefixs (including Wikipedia: on other projects)

A test case https://zh.wikiversity.org/w/index.php?oldid=122430

TTO closed this task as Declined.Mar 28 2019, 11:05 AM
TTO added a subscriber: TTO.

This is on purpose; the long names always link to the English project. To change this would be incredibly disruptive.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptMar 28 2019, 11:05 AM