Page MenuHomePhabricator

Hovering over a "D" in Watchlist on enwp produces text with embedded markup (due to locally overwritten message)
Closed, InvalidPublic

Description

In my en Wikipedia Watchlist, when I hover over a "D" on the left of a history item, a small pop-up box appears with an explanation of the symbol. However the explanatory text shown in the box reads:

Edit made at Wiki<span style="text_decoration: underline;">d</span>ata

Obviously the intent is to display the word "Wikidata" with an underlined "d", but the box isn't rendering the underline and the text actually displayed would be very confusing to a non-techie. Hover-over boxes for other symbols (x and m) do not have a similar problem.

The simplest fix would be to get rid of the markup. I think our readers can figure out that the D stands for data without the underline hint.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 21 2019, 7:41 PM
Ammarpad added a subscriber: Ammarpad.EditedMar 22 2019, 5:38 AM

The source message does not have that markup, apparently because it was meant to be plain text. The message was customized to use template on en.wiki to add underlining. So please ask them to either remove that template or completely delete the message so as to fallback to default.

Ammarpad closed this task as Invalid.Mar 22 2019, 1:30 PM

Thanks for tracking down the edit that caused this problem. I contacted the editor who made it and he reversed it, and so the problem is fixed. Apparently the same text string is used in the “List of abbreviations” box in the upper right of the Watchlist and the markup does work there. The fact that the string is used in two places with possibly different results should at least be documented somewhere.

Best,

Arnold Reinhold

Thank you @ArnoldReinhold. Actually the text of the upper right box already has a separate message, MediaWiki:Wikibase-rc-wikibase-edit-legend but it was not defined. So the one for the tooltip was transcluded there. I will attempt the simple fix of defining it since both messages can be styled differently.

Aklapper renamed this task from Hovering over a "D" in Watchlist produces text with embedded markup to Hovering over a "D" in Watchlist on enwp produces text with embedded markup (due to locally overwritten message).Apr 1 2019, 6:57 AM