Page MenuHomePhabricator

IABot 2.0beta14 is adding newlines at random places
Closed, ResolvedPublic

Description

https://cs.wikipedia.org/w/index.php?title=Esperanto&diff=prev&oldid=17122951, https://cs.wikipedia.org/w/index.php?diff=17122956 is an example. Newlines after <ref> aren't wanted.

Newlines within random parts of the parameters are even less wanted, https://cs.wikipedia.org/w/index.php?title=Mir&diff=17122996&oldid=16285520.

I've disabled the bot locally till this is resolved, feel free to enable again once this is resolved.

Event Timeline

Urbanecm created this task.Apr 6 2019, 10:13 PM
Restricted Application assigned this task to Cyberpower678. · View Herald TranscriptApr 6 2019, 10:13 PM
Restricted Application added a subscriber: Cyberpower678. · View Herald Transcript
Urbanecm renamed this task from IABot's adding newlines after<ref>tag to IABot's adding newlines after<ref>tag and before </ref> tag.Apr 6 2019, 10:14 PM
Urbanecm updated the task description. (Show Details)
Urbanecm renamed this task from IABot's adding newlines after<ref>tag and before </ref> tag to IABot's adding newlines at random places.Apr 6 2019, 10:26 PM
Urbanecm updated the task description. (Show Details)
Urbanecm updated the task description. (Show Details)

I've disabled the bot locally till this is resolved, feel free to enable again once this is resolved.

Dvorapa added a subscriber: Dvorapa.
Cirdan renamed this task from IABot's adding newlines at random places to IABot 2.0beta14 is adding newlines at random places.May 12 2019, 10:00 AM
Cirdan edited projects, added InternetArchiveBot (v2.0); removed InternetArchiveBot.
Cirdan moved this task from Unsorted to Bugs on the InternetArchiveBot (v2.0) board.
Cirdan added a subscriber: Cirdan.
Cyberpower678 closed this task as Resolved.May 26 2019, 8:41 PM
Urbanecm reopened this task as Open.May 26 2019, 8:58 PM

Not fully resolved, https://cs.wikipedia.org/w/index.php?diff=prev&oldid=17274856 still adds a newline after <ref> and before {{Citace elektronické monografie, and it says beta15.

This is weird. It works as intended on my local installation but fails on production. I don’t really get why though.

Cyberpower678 closed this task as Resolved.Jun 12 2019, 12:01 PM