Page MenuHomePhabricator

IABot 2.0beta14 repeatedly adds archive template in nested template
Closed, ResolvedPublicBug

Description

On ckb wiki, Internet Archive Bot went crazy on this page and added 2,059,202 bites of data to the page, attempting to tag one of the links with the dead link template dozens of times. I’m not sure why it did this. I hope someone can look into it.

Example Diff

Event Timeline

Epine created this task.May 13 2019, 7:28 AM
Restricted Application added a project: Internet-Archive. · View Herald TranscriptMay 13 2019, 7:28 AM
Cirdan renamed this task from InternetArchiveBot repeatedly attempted archiving one link dozens of times to IABot 2.0beta14 repeatedly adds archive template in nested template.May 15 2019, 4:33 AM
Cirdan updated the task description. (Show Details)
Cirdan moved this task from Unsorted to Bugs on the InternetArchiveBot (v2.0) board.
Cirdan added a subscriber: Cirdan.
Epine added a comment.May 23 2019, 4:14 PM

I just had to force the bot from editing the page. I hope someone can take care of this.

I have a hard time understanding the reason for these edits from the diffs. Could you extract the original template insertion (prior to any IABot edits) and post it here?

Also, why does the bot reach this page so frequently? It should cycle through the alphabet and only reach a certain article every couple of months (depending on the total number of articles in your Wikipedia), unless it is called explicitly on a page using the Management Interface.

Epine added a comment.May 23 2019, 5:05 PM

@Cirdan IAB tags this template from the infobox repeatedly: {{url|https://www.libreoffice.org/}}. I don’t know why it returns to the page frequently. It may be because we have a low number of articles (23,000 articles)

Cirdan added a comment.EditedMay 23 2019, 5:10 PM

Can you post the entire infobox/template structure around it as well, please? I'll go check the template definitions for your wiki in the meantime.

Epine added a comment.EditedMay 23 2019, 5:15 PM

@Cirdan it’s exactly the same as the English Wikipedia. We use the same code and translate the visible texts. Here is the code:

{{Infobox software
| logo                 = [[File:LibreOffice Logo Flat.svg|240px]]
| screenshot           = LibreOffice 6.0.1.1 Start Center Screenshot.png
| caption              = لیبرەئۆفیس وشانی٦٫١
| author               = [[Star Division]]<!-- Original author or the software that led to LO -->
| released             = {{Start date and age|٢٠١١|١|٢٥|df=yes}}<!-- Initial release is the first stable version of the software. -->
| programming language = [[C++]], [[Java (programming language)|Java]], وە [[Python (programming language)|Python]]<ref>{{cite web
| publisher   = [[The Document Foundation]]
| work        = Wiki
| date        = 13 November 2012
| accessdate  = 9 March 2013
| operating system     = [[Linux]], [[Microsoft Windows|Windows]] 7+ ([[Windows XP|XP]] and [[Windows Vista|Vista]] for 5.x), [[macOS]] 10.9+, [[Android (operating system)|Android (Viewer)]];
| language count       = ١١٥
| genre                = [[Office suite]]
| license              = [[Mozilla Public License|MPLv2.0]] (secondary license [[GNU General Public License|GPL]], [[GNU Lesser General Public License|LGPLv3+]] or [[Apache License 2.0]])<ref name="About">{{cite web
  | title       = Licenses
  | url         = https://www.libreoffice.org/download/license/
  | publisher   = [[The Document Foundation]]
  | accessdate  = 16 December 2015}}</ref>
| standard    = [[OpenDocument]]
| website     = {{url|https://www.libreoffice.org/}}
}}

The section that causes the problem is the website field of the infobox.

There is a missing </ref> in your code: diff.

I tried to fix it on your Wikipedia, but it seems that there have been changes in the meantime.

Epine added a comment.May 23 2019, 5:32 PM

@Cirdan, I’m confused. If you’re referring to the closing ref code (</ref>) it is included in both the article and the code above in the accessdate section.

No, Python]]<ref>{{cite web is never closed as far AS I can see. I get an error on dewiki when I paste the code.

Epine added a comment.May 23 2019, 5:52 PM

@Cirdan thanks. Now I feel like a total idiot!

Epine closed this task as Resolved.May 23 2019, 5:53 PM
Epine reopened this task as Open.May 23 2019, 11:45 PM

@Cirdan it happened again? *face palm* I’m doing some changes to the URL templates, maybe it’s not the bot because it’s been observed to only act like that on that specific page *so far*.

IABot should only touch URLs within references, unless you configured it otherwise. So I thought the messed up reference structure might have been the issue.

Let's be systematic here. Can you please take the part with the Infobox and post it on a page in your user name space? Then we can run the bot there and figure out why it fails.

It seems that this edit fixed the problem. I just ran the bot on this page and it did not try to make any modifications. Can you confirm that all is well now?

Cirdan closed this task as Resolved.May 26 2019, 9:40 AM

Please reopen if the problem appears again.