Page MenuHomePhabricator

Change spaces to underscores in values of $wgMetaNamespace for urwiktionary, urwikibooks and urwikiquote
Closed, DuplicatePublic

Description

The values of $wgMetaNamespace for urwiktionary, urwikibooks and urwikiquote contain spaces that need to be underscores instead (as noted at mw:Manual:$wgMetaNamespace).

Hence the following values should be set:

'wgMetaNamespace' => [
  'urwikibooks' => 'ویکی_کتب',
  'urwikiquote' => 'ویکی_اقتباس',
  'urwiktionary' => 'ویکی_لغت',
]

Fixing this may also fix the bug reported at T223039. (Maybe. I'm not sure.)

I don't know if a script needs to be run after this change is made.

Details

Related Gerrit Patches:

Event Timeline

Dcljr created this task.May 21 2019, 9:05 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 21 2019, 9:05 AM

Pinging @Tulsi_Bhagat, who made the changes requested in T214290.

Please note that the values used in $wgSitename do not need to be changed (spaces are OK there).

Looking into it. Sorry for the inconvenience!

Tulsi_Bhagat triaged this task as Medium priority.May 21 2019, 10:38 AM
Tulsi_Bhagat moved this task from Backlog to Config - to process on the Wikimedia-Site-requests board.

Change 511868 had a related patch set uploaded (by Tulsi Bhagat; owner: Tulsi Bhagat):
[operations/mediawiki-config@master] Configuring $wgMetaNamespace for ur.wiktionary, ur.wikibooks and ur.wikiquote

https://gerrit.wikimedia.org/r/511868

Requires namespaceDupes.php --wiki=urwikibooks --fix after deployment.
Requires namespaceDupes.php --wiki=urwikiquote --fix after deployment.
Requires namespaceDupes.php --wiki=urwiktionary --fix after deployment.

Dcljr added a subscriber: Urbanecm.May 25 2019, 8:44 AM

@Tulsi_Bhagat please note that @Urbanecm has submitted a patch similar, but not identical, to yours in response to T223039: Project pages inaccessible on several projects because of spaces in wgMetaNamespace(Talk):

https://gerrit.wikimedia.org/r/512426

His patch also fixes a space in the value of $wgMetaNamespaceTalk for aswikisource.

You two should probably decide which patch should be withdrawn.

@Tulsi_Bhagat please note that @Urbanecm has submitted a patch similar, but not identical, to yours in response to T223039: Project pages inaccessible on several projects because of spaces in wgMetaNamespace(Talk):
https://gerrit.wikimedia.org/r/512426
His patch also fixes a space in the value of $wgMetaNamespaceTalk for aswikisource.
You two should probably decide which patch should be withdrawn.

@Dcljr Don't worry. We will take care of it.

Since my patch fixes the same error also for another project, i recommend abandoning Tulsi's patch in favour of mine. Also closed this as a dupe of T223039, since both are about the same thing.

Change 511868 abandoned by Urbanecm:
Configuring $wgMetaNamespace for ur.wiktionary, ur.wikibooks and ur.wikiquote

Reason:
Abandoning in favor of 9b28877, which is already merged and deployed.

https://gerrit.wikimedia.org/r/511868