Page MenuHomePhabricator

Remove leading PMC from PMC field
Closed, ResolvedPublicBUG REPORT

Description

There are two PMCs in PMC field from this url from the citoid rest service: https://www.ncbi.nlm.nih.gov/pmc/articles/PMC4241502/

Details

Related Gerrit Patches:
mediawiki/services/citoid : masterRemove PMC prefix in PMCID field

Event Timeline

Mvolz created this task.May 21 2019, 1:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 21 2019, 1:11 PM
Mvolz updated the task description. (Show Details)May 21 2019, 1:27 PM

The cause of this problem has been identified. Given that

const rePMCID = new RegExp('\\bPMC\\d{7}\\b');

If this condition is satisfied, keyValue[1].trim() must have already contained a 'PMC' prefix. Thus the next line

content.PMCID = `PMC${keyValue[1].trim()}`;

would result in a duplication of the 'PMC' prefix.

Mvolz moved this task from Backlog to Service on the Citoid board.Jun 2 2019, 6:00 PM

Change 513767 had a related patch set uploaded (by Mvolz; owner: Mvolz):
[mediawiki/services/citoid@master] Remove PMC prefix in PMCID field

https://gerrit.wikimedia.org/r/513767

Change 513767 merged by jenkins-bot:
[mediawiki/services/citoid@master] Remove PMC prefix in PMCID field

https://gerrit.wikimedia.org/r/513767

Mvolz claimed this task.Jun 10 2019, 1:05 PM
Mvolz closed this task as Resolved.Jun 10 2019, 1:23 PM
Mvolz triaged this task as Medium priority.
Mvolz removed a project: Patch-For-Review.
Mvolz reopened this task as Open.Jun 11 2019, 9:14 AM
Mvolz moved this task from Service to Waiting on Deploy on the Citoid board.
Mvolz closed this task as Resolved.Jul 13 2019, 9:08 AM