Option to sort search results by size, number of words and date in advanced
OpenPublic

Description

Since the search results give the size and date of latest modification (at the time of the indexing), I suppose the results can be sorted by size and date. So it's a request to add those options for advanced searches, below Search by namespaces:

Sort by:
relevance (the default) . size . date of latest modification

Both would be helpful in particular for certain maintenance tasks, sorting by size for stubs and short pages, and sorting by date of latest modification to detect pages not edited for a long time for example.


Version: unspecified
Severity: enhancement

bzimport added a project: MediaWiki-Search.Via ConduitNov 21 2014, 10:56 PM
bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz21139.
Cenarium created this task.Via LegacyOct 14 2009, 5:28 PM
brion added a comment.Via ConduitOct 14 2009, 5:36 PM

Robert, is that feasible for the Lucene index?

To do it in the MySQL backend we'd need to add those fields to searchindex (or else build a temporary table w/ results -- anything to avoid joining searchindex and page which is the Performance Kiss Of Death) and I'm still not sure how efficient that would run.

bzimport added a comment.Via ConduitFeb 28 2012, 11:07 PM

rd232 wrote:

Any update on feasibility of sorting search results?

bzimport added a comment.Via ConduitMay 3 2013, 7:42 PM

nilesh wrote:

Can Lucene 3.4.0 (at least) be used with MediaWiki? Are there any problems/limitations?

It has support for index-time joins that denormalize relational database tables so that we can simply search over those tables in real time without any joining overhead. Please check the docs for the same for v 3.6.0 here - http://lucene.apache.org/core/3_6_0/api/contrib-join/org/apache/lucene/search/join/package-summary.html

What do you think about using it?

Aklapper added a comment.Via ConduitMay 6 2013, 8:59 AM

(In reply to comment #3)

Can Lucene 3.4.0 (at least) be used with MediaWiki? Are there any
problems/limitations?

https://wikitech.wikimedia.org/wiki/Search has info about the search infra and what's used with what. Let's please keep this bug report specific and focused.

Cenarium changed the title from "Option to sort search results by size and date in advanced" to "Option to sort search results by size, number of words and date in advanced".Via WebDec 14 2014, 2:31 AM
Cenarium added a project: CirrusSearch.
Cenarium set Security to None.
Cenarium added a comment.Via WebDec 14 2014, 2:34 AM

Added project CirrusSearch since it's the new search engine used by wikimedia wikis. Also added number of words as criteria since it is also shown on search results.

Cenarium added a comment.Via WebDec 14 2014, 3:23 AM

Just noticed T11519, I'll fill a separate bug for date of latest modification, and another for multimedia search options.

Cenarium closed this task as a duplicate of T11519: Search by page size.Via WebDec 14 2014, 3:24 AM
Cenarium reopened this task as "Open".Via WebDec 14 2014, 4:06 AM

Oops, not a duplicate, this is a request for sorting the results, not for filtering them. Note that for multimedia searches, size should mean file size.

Add Comment