Page MenuHomePhabricator

Comments not working on 1.34.1
Closed, InvalidPublicBUG REPORT

Description

Steps to Reproduce:
installed comments,
comments working normally until a typo in options when using <comments xxx />,
database error,
uninstalled comments, run the update.php, deleted three tables related to comments in wikidb, reinstalled comments, run the update.php
still have database error when using even normal <comments />

Actual Results:

Function: CommentsPage::getComments
Error: 1054 Unknown column 'stats_user_id' in 'on clause' (localhost)
  • similar to first bullet point here? the follow-up of that discussion says the comment extension is not working...

Expected Results:
working comments

Event Timeline

Timingliu created this task.Jun 8 2020, 9:46 AM
Restricted Application added a project: Social-Tools. · View Herald TranscriptJun 8 2020, 9:46 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Timingliu updated the task description. (Show Details)Jun 8 2020, 9:47 AM

installed comments,

@Timingliu: Which exact version / revision?

ashley closed this task as Invalid.Jun 9 2020, 8:19 AM
ashley added a subscriber: ashley.

Update Comments and/or SocialProfile and/or any and all other Social-Tools to their latest version (master, not REL1_34 or any other release branch version! See social tools' MW compatibility policy for details.) Comments hasn't referenced SocialProfile's user_stats' stats_user_id field since late January 2020 (7c9a27d996aa27b3cb7669c28b96784e19ff3dd6).