Page MenuHomePhabricator

Problem with search function that could lead to new articles with incorrect titles
Closed, DeclinedPublic

Description

If you type a search query on English Wikipedia in quotes and the result shows a red link, it appears that someone can create an article with quotes around the title. I don't know how big a problem this is, but I can see it being a problem. The problem was pointed out in the final response to [https://en.wikipedia.org/wiki/Wikipedia:Help_desk/Archives/2020_August_15#my_name_is_John_Pappas_and_you_say_I_have_no_page._well_type_my_name_on_Google_and_my_Wikipedia_page_comes_up._I_gave_a_donation_to_you_yesterday._I_have_donated_many_times._I'd_to_clear_this_up. this help desk question].

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 3 2020, 4:36 PM
Aklapper closed this task as Declined.Nov 3 2020, 4:55 PM
Aklapper added a project: MediaWiki-Search.

Hi @Vchimpanzee, thanks for taking the time to report this! For future reference, please always follow https://www.mediawiki.org/wiki/How_to_report_a_bug .

This seems to be about the custom message You may create the page "$1". defined locally in https://en.wikipedia.org/wiki/MediaWiki:Searchmenu-new . That's a customization of the English Wikipedia community.
The default string in MediaWiki that would be displayed in this case is
<strong>Create the page \"[[:$1]]\" on this wiki!</strong> {{PLURAL:$2|0=|See also the page found with your search.|See also the search results found.}} according to https://phabricator.wikimedia.org/source/mediawiki/browse/master/languages/i18n/en.json

I don't think that software complexity (and maintenance costs) should be introduced to either outsmart or confuse the user what they meant to enter though did not enter here, and strip random quotation marks, so I am going to boldly decline this.

Restricted Application added a project: Discovery-Search. · View Herald TranscriptNov 3 2020, 4:55 PM

Understood. I wondered if it would even be worth it. I have sent a message to the person who brought the issue up on the Help Desk.

I guess no matter if you strip them or not, someone will either consider it unexpected behavior, or someone will do it wrong. :-/