Page MenuHomePhabricator

discrepancy between "Showing below up to NNNN results starting with #1." and displayed list
Closed, ResolvedPublic

Description

Author: gangleri

Description:
URL: http://test.leuksman.com/index.php?title=Special:Listusers&limit=500&offset=0
verified at http://jadesukka.homelinux.org:8180/betawiki/Toiminnot:Listusers

is OK at http://yi.wikipedia.org/wiki/Special:Listusers

Hi! Maybe some "users" as [[User:MediaWiki default]] or [[User:Template
namespace initialisation script]] are counted as well.

See

  1. [[Special:Contributions/MediaWiki default]]
  2. [[Special:Contributions/Template namespace initialisation script]]

Regards Reinhardt [[user:gangleri]]


Version: 1.5.x
Severity: normal
URL: http://test.leuksman.com/index.php?title=Special:Listusers&limit=500&offset=0

Details

Reference
bz2161

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 8:28 PM
bzimport set Reference to bz2161.
bzimport added a subscriber: Unknown Object (MLST).

gangleri wrote:

Please see
http://jadesukka.homelinux.org:8180/betawiki/Image:Special_listusers_01.jpg

After update to CVS:

It seems that

  • the list is not sorted alphabeticaly
  • users belonging to multiple groups are counted for each group
  • the counters at the top and at the bottom are now identical

Note before the groups where separated with commas.

Regards Reinhardt [[user:gangleri]]

zigger wrote:

yi.wikipedia.org runs 1.4, which is why it works there.

I see the reported problems with my 1.5 test database, probably caused by the
changes for bug 968. Additionally, the groups are shown as numbers.

It looks ok, except for the sorting bug, at
http://test.leuksman.com/index.php?title=Special:Listusers&limit=500
But users do not seem to be in multiple groups there.

Upgrading 1.5 test wikis is not a priority, but how is it on 1.4 upgrades?

On a new 1.5 install, I see the sort bug, the count bug and the missing commas.

Fixed this a while ago.