Page MenuHomePhabricator

No longer able to move subpages if moving to a different namespace (e.g. ns0 to ns1)
Closed, ResolvedPublic

Description

Due to the new [horrible!] dropdown namespace selector [boooo], it's no longer possible to move (sub)pages across namespace.
Steps to reproduce (I guess):

  1. Create N:A e N:A/B
  2. Click move and select "M" in namespace dropdown
  3. Choose to move subpages
  4. Confirm

Expected result: N:A is moved to M:A and N:A/B to M:A/B.
Actual result: N:A/B is left behind and you're told that moving is impossible.

Example: see URL (last five moves were done by hand).

(Can we just drop this buggy dropdown selector that was introduced for no reason?)


Version: 1.21.x
Severity: major
URL: https://meta.wikimedia.org/w/index.php?title=Special:Log/Nemo_bis&offset=20121111181700&limit=6&type=&user=Nemo+bis

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 12:59 AM
bzimport set Reference to bz42024.
Nemo_bis created this task.Nov 11 2012, 6:33 PM

(In reply to comment #0)

Steps to reproduce (I guess):

I tried that with N=Help and M=Project, but it worked fine.

Back to NEW. The steps to reproduce might be wrong but I've provided logs which prove it.

bello.a wrote:

I tried this:

  1. Create in the main namespace the page Test/Test
  2. Create the pages Test/Test/1, Test/Test/2, Test/Test/3
  3. Go to Test/Test and try to move to the Discussions namespace INCLUDING subpages.

Expected results:
• Test/Test moved to Discussions:Test/Test
• Test/Test/1 moved to Discussions:Test/Test/1
• Test/Test/2 moved to Discussions:Test/Test/2
• Test/Test/3 moved to Discussions:Test/Test/3

Results:
• Test/Test moved to Discussions:Test/Test
• Subpages not moved because the software tries to move Test/Test/1 to the same Test/Test/1 and not to the discussions namespace.

N.B.: Tried only with the main namespace and "Discussions" namespace, it MAY happen also between other namespaces.

Thanks for confirming the bug. (Note that Riccardo had to enable subpages on main namespace for the test wiki of course.)

Change 151084 had a related patch set uploaded by Rohan013:
Move subpages between subject and talk namespace

https://gerrit.wikimedia.org/r/151084

Change 151084 had a related patch set uploaded (by Krinkle):
Move subpages between subject and talk namespace

https://gerrit.wikimedia.org/r/151084

Patch-For-Review

Change 151084 merged by jenkins-bot:
SpecialMovepage: Correctly apply target namespace to subpages

https://gerrit.wikimedia.org/r/151084

Nemo_bis closed this task as Resolved.Jan 28 2015, 2:42 PM
Nemo_bis added a project: MW-1.25-release.
Nemo_bis set Security to None.