Page MenuHomePhabricator

Dirty background shown on scaled GIF images due to imagemagick's convert tool
Closed, ResolvedPublic

Description

Compare http://upload.wikimedia.org/wikipedia/zh/e/eb/CASC.gif and http://upload.wikimedia.org/wikipedia/zh/thumb/e/eb/CASC.gif/220px-CASC.gif

P.S. We don't have an "image scaler" bugzilla component?


Version: unspecified
Severity: minor

Details

Reference
bz43454

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:09 AM
bzimport set Reference to bz43454.
bzimport added a subscriber: Unknown Object (MLST).
liangent created this task.Dec 27 2012, 5:12 AM

(In reply to comment #0)

P.S. We don't have an "image scaler" bugzilla component?

That's bug 41371.

(In reply to comment #0)
I can not see anything wrong with the image and it's thumbnail.
(There is some #fefefe-white as background in the source gif file. If this is the problem, I could easily fix that for you)

(In reply to comment #2)

(In reply to comment #0)
I can not see anything wrong with the image and it's thumbnail.
(There is some #fefefe-white as background in the source gif file. If this is
the problem, I could easily fix that for you)

I'm talking about those #f6f9fe pixels.

More precisely, those #fefefe are darkened into #f6f9fe, and lose a clear boundary.

This seems to be an upstream bug of imagemagick's convert command line tool. (I could reproduce similar results). You may file a bug at http://www.imagemagick.org/discourse-server/viewforum.php?f=3

jijiki added a project: Thumbor.
jijiki added a subscriber: jijiki.

Reopen if needed, images look alright now.

Gilles closed this task as Resolved.Feb 26 2019, 1:00 PM
Gilles claimed this task.